wpa_supplicant: add mesh support (IEEE 80211s)
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 7 Nov 2016 11:17:24 +0000 (12:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 7 Nov 2016 21:55:49 +0000 (22:55 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wpa_supplicant/Config.in
package/wpa_supplicant/wpa_supplicant.mk

index 454541fdce71276b4cf0d256fba8499ab8bb2fe0..9250a3b20010f75e528cd686ab2be54888ce81c5 100644 (file)
@@ -45,6 +45,13 @@ config BR2_PACKAGE_WPA_SUPPLICANT_WIFI_DISPLAY
        help
          Enable support for Wi-Fi Display
 
+config BR2_PACKAGE_WPA_SUPPLICANT_MESH_NETWORKING
+       bool "Enable mesh networking"
+       depends on BR2_PACKAGE_WPA_SUPPLICANT_AP_SUPPORT
+       help
+         Enable support for open and secured mesh networking
+         (IEEE 802.11s)
+
 config BR2_PACKAGE_WPA_SUPPLICANT_AUTOSCAN
        bool "Enable autoscan"
        help
index 3c3317b1224e6642a9cb9f5eec69929f45f24657..9c8414b56828a38c89c5f47df3acbf2e77b168d4 100644 (file)
@@ -73,6 +73,11 @@ ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_WIFI_DISPLAY),y)
 WPA_SUPPLICANT_CONFIG_ENABLE += CONFIG_WIFI_DISPLAY
 endif
 
+ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_MESH_NETWORKING),y)
+WPA_SUPPLICANT_CONFIG_SET += CONFIG_MESH
+WPA_SUPPLICANT_CONFIG_ENABLE += CONFIG_IEEE80211W
+endif
+
 ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_AUTOSCAN),y)
 WPA_SUPPLICANT_CONFIG_ENABLE += \
        CONFIG_AUTOSCAN_EXPONENTIAL \