mtools: ensure install-info isn't used
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 31 May 2016 19:57:15 +0000 (21:57 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 31 May 2016 20:10:29 +0000 (22:10 +0200)
mtools calls install-info at 'make install' time if available after
installing the mtools info page - But as we don't use the info pages for
anything / remove in target-finalize, this is a waste of time and a
potential cause of build failures as reported on the list:

http://lists.busybox.net/pipermail/buildroot/2016-May/160604.html

So ensure configure doesn't find it.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mtools/mtools.mk

index d331af25fa52bbc5aca5b27582f1e4d88f700f0f..fc145c0832066f805d396b0ab84bb42dda583244 100644 (file)
@@ -9,8 +9,14 @@ MTOOLS_SOURCE = mtools-$(MTOOLS_VERSION).tar.bz2
 MTOOLS_SITE = $(BR2_GNU_MIRROR)/mtools
 MTOOLS_LICENSE = GPLv3+
 MTOOLS_LICENSE_FILES = COPYING
-MTOOLS_CONF_ENV = ac_cv_func_setpgrp_void=yes
 MTOOLS_CONF_OPTS = --without-x
+# info documentation not needed
+MTOOLS_CONF_ENV = \
+       ac_cv_func_setpgrp_void=yes \
+       ac_cv_path_INSTALL_INFO=
+
+HOST_MTOOLS_CONF_ENV = \
+       ac_cv_path_INSTALL_INFO=
 
 # link with iconv if enabled
 ifeq ($(BR2_PACKAGE_LIBICONV),y)