python-flup: new package
authorOli Vogt <oli.vogt.pub01@gmail.com>
Sun, 25 May 2014 08:24:17 +0000 (20:24 +1200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 27 Jul 2014 13:31:04 +0000 (15:31 +0200)
This module is useful to implement a fastCGI webserver
Tested with ARM and Python 2.7.6

[Thomas: fix license informations.]

Signed-off-by: oli vogt <oli.vogt.pub01@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-flup/Config.in [new file with mode: 0644]
package/python-flup/python-flup.mk [new file with mode: 0644]

index 8de06e272cdfbbadba2cf73897e6a329752d2927..ce479842f32c76adfd2002f9f1ec06970988d77d 100644 (file)
@@ -473,6 +473,7 @@ menu "external python modules"
        source "package/python-crc16/Config.in"
        source "package/python-dialog/Config.in"
        source "package/python-dpkt/Config.in"
+       source "package/python-flup/Config.in"
        source "package/python-id3/Config.in"
        source "package/python-ipy/Config.in"
        source "package/python-json-schema-validator/Config.in"
diff --git a/package/python-flup/Config.in b/package/python-flup/Config.in
new file mode 100644 (file)
index 0000000..2c21323
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_FLUP
+       bool "python-flup"
+       depends on BR2_PACKAGE_PYTHON
+       help
+         flup provides of a collection of WSGI modules for Python.
+         It allows a webserver to use scgi-mod and fastcgi-mod
+         with python.
+
+         https://pypi.python.org/pypi/flup
diff --git a/package/python-flup/python-flup.mk b/package/python-flup/python-flup.mk
new file mode 100644 (file)
index 0000000..39c6658
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# python-flup
+#
+################################################################################
+
+PYTHON_FLUP_VERSION = 1.0.3.dev-20110405
+PYTHON_FLUP_SOURCE = flup-$(PYTHON_FLUP_VERSION).tar.gz
+PYTHON_FLUP_SITE = http://pypi.python.org/packages/source/f/flup
+
+PYTHON_FLUP_LICENSE = BSD-2c
+
+PYTHON_FLUP_SETUP_TYPE = setuptools
+
+$(eval $(python-package))