collectd: fix riemann write plugin dependencies
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 28 Dec 2016 22:18:06 +0000 (23:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 3 Jan 2017 22:48:59 +0000 (23:48 +0100)
Fixes:
http://autobuild.buildroot.org/results/fe5/fe5b5ed6355a794e84894c4aaf62eda6529ed184/
http://autobuild.buildroot.org/results/6c3/6c393cffb6ad4e676e311e9fc23ddbb2bcc2cf36/

The plugin uses the riemann-c-client library since commit d55584214206
(write_riemann: Use riemann-c-client), so adjust the dependencies to match.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/collectd/Config.in
package/collectd/collectd.mk

index ab49b71e02d26d86c75171692c89e0cb6b792c36..683141b1209b377eaf1a952c498ffff7794106f5 100644 (file)
@@ -550,7 +550,7 @@ config BR2_PACKAGE_COLLECTD_RIEMANN
        depends on BR2_INSTALL_LIBSTDCPP # protobuf
        # protobuf-c -> host-protobuf
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
-       select BR2_PACKAGE_PROTOBUF_C
+       select BR2_PACKAGE_RIEMANN_C_CLIENT
        select BR2_PACKAGE_LIBTOOL
        help
          Sends data to Riemann, a stream processing and monitoring system.
index 28c1b31e0990d14476c2620a5c0b79889bec7c21..7ab7dd4223c0b63a2878d65c4a96308b996e3d36 100644 (file)
@@ -146,7 +146,7 @@ COLLECTD_DEPENDENCIES = \
        $(if $(BR2_PACKAGE_COLLECTD_OPENLDAP),openldap) \
        $(if $(BR2_PACKAGE_COLLECTD_PING),liboping) \
        $(if $(BR2_PACKAGE_COLLECTD_POSTGRESQL),postgresql) \
-       $(if $(BR2_PACKAGE_COLLECTD_RIEMANN),libtool protobuf-c) \
+       $(if $(BR2_PACKAGE_COLLECTD_RIEMANN),libtool riemann-c-client) \
        $(if $(BR2_PACKAGE_COLLECTD_RRDTOOL),rrdtool) \
        $(if $(BR2_PACKAGE_COLLECTD_SENSORS),lm-sensors) \
        $(if $(BR2_PACKAGE_COLLECTD_SMART),libatasmart) \