squashfs: always enable xattr support
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Fri, 20 Nov 2015 13:34:15 +0000 (10:34 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Nov 2015 14:43:07 +0000 (15:43 +0100)
In 785fef10 xattr support was disabled, probably because the old version
did require the xattr package to be present to support it.
In a409d76e xattr support was made optional via (lib)attr, however the
squashfs package does in fact include all of the required bits to
support xattr without the need for the attr package.

So enable xattr support by default for both the host and target
variants.

Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/squashfs/squashfs.mk

index 3204d0545863376a864b2e16b673fc9ab98a1772..cdeb9c8f72240a9cc27c74a386bdebcc23307e3e 100644 (file)
@@ -9,13 +9,7 @@ SQUASHFS_SOURCE = squashfs$(SQUASHFS_VERSION).tar.gz
 SQUASHFS_SITE = http://downloads.sourceforge.net/project/squashfs/squashfs/squashfs$(SQUASHFS_VERSION)
 SQUASHFS_LICENSE = GPLv2+
 SQUASHFS_LICENSE_FILES = COPYING
-
-ifeq ($(BR2_PACKAGE_ATTR),y)
-SQUASHFS_DEPENDENCIES += attr
-SQUASHFS_MAKE_ARGS += XATTR_SUPPORT=1
-else
-SQUASHFS_MAKE_ARGS += XATTR_SUPPORT=0
-endif
+SQUASHFS_MAKE_ARGS = XATTR_SUPPORT=1
 
 ifeq ($(BR2_PACKAGE_SQUASHFS_LZ4),y)
 SQUASHFS_DEPENDENCIES += lz4
@@ -54,9 +48,8 @@ endif
 
 HOST_SQUASHFS_DEPENDENCIES = host-zlib host-lz4 host-lzo host-xz
 
-# no libattr/xz in BR
 HOST_SQUASHFS_MAKE_ARGS = \
-       XATTR_SUPPORT=0 \
+       XATTR_SUPPORT=1 \
        XZ_SUPPORT=1    \
        GZIP_SUPPORT=1  \
        LZ4_SUPPORT=1   \