package/wireshark: add zstd optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 1 Nov 2020 12:05:58 +0000 (13:05 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 1 Nov 2020 14:59:37 +0000 (15:59 +0100)
zstd is available since version 3.1.1 and is enabled by default:
https://github.com/wireshark/wireshark/commit/ad94c4d459d243c0cbbb9b222d5f7cdf8189ab86

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/wireshark/wireshark.mk

index 0bcb97606a1186c3fe3bd6398ca4425d9a767f0f..0d4fedb3f0774c957154f2702ba97b99a047468c 100644 (file)
@@ -155,6 +155,13 @@ else
 WIRESHARK_CONF_OPTS += -DBUILD_sdjournal=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_ZSTD),y)
+WIRESHARK_CONF_OPTS += -DENABLE_ZSTD=ON
+WIRESHARK_DEPENDENCIES += zstd
+else
+WIRESHARK_CONF_OPTS += -DENABLE_ZSTD=OFF
+endif
+
 # Disable plugins as some of them (like l16mono) can't be built
 # statically. ENABLE_STATIC=ON actually means "disable shared library"
 # and ENABLE_STATIC=OFF means "enable shared library". So for the