package/kismet: add python tools support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 4 Oct 2020 15:50:04 +0000 (17:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 15 Oct 2020 21:10:24 +0000 (23:10 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/kismet/Config.in
package/kismet/kismet.mk

index 8c4c63d9ed8105b37004cd3354b05b229b98ccec..4ef84731da854b8770cb2704be6de5d6a9a66895 100644 (file)
@@ -26,6 +26,34 @@ config BR2_PACKAGE_KISMET
 
 if BR2_PACKAGE_KISMET
 
+config BR2_PACKAGE_KISMET_PYTHON_TOOLS
+       bool "Install python tools"
+       depends on BR2_PACKAGE_PROTOBUF_ARCH_SUPPORTS # protobuf
+       depends on BR2_PACKAGE_PYTHON_NUMPY_ARCH_SUPPORTS # python-numpy
+       depends on BR2_PACKAGE_PYTHON3
+       depends on !BR2_STATIC_LIBS # protobuf
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # protobuf
+       depends on BR2_TOOLCHAIN_USES_GLIBC || BR2_TOOLCHAIN_USES_MUSL # python-numpy
+       select BR2_PACKAGE_PROTOBUF
+       select BR2_PACKAGE_PYTHON_NUMPY # runtime for RTLAMR and RTLADSB
+       select BR2_PACKAGE_PYTHON_PROTOBUF # runtime
+       select BR2_PACKAGE_PYTHON_SERIAL # runtime for Freaklabs Zigbee
+       select BR2_PACKAGE_PYTHON_SETUPTOOLS
+       help
+         Enable Python and Python-related tools (RTL_433, RTLAMR,
+         RTLADSB and Freaklabs Zigbee)
+
+comment "python tools needs python3"
+       depends on !BR2_PACKAGE_PYTHON3
+       depends on BR2_PACKAGE_PROTOBUF_ARCH_SUPPORTS
+       depends on BR2_PACKAGE_PYTHON_NUMPY_ARCH_SUPPORTS
+
+comment "python tools needs a glibc or musl toolchain w/ dynamic library, gcc >= 4.8"
+       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
+       depends on BR2_PACKAGE_PROTOBUF_ARCH_SUPPORTS
+       depends on BR2_PACKAGE_PYTHON_NUMPY_ARCH_SUPPORTS
+       depends on !(BR2_TOOLCHAIN_USES_GLIBC || BR2_TOOLCHAIN_USES_MUSL)
+
 config BR2_PACKAGE_KISMET_SERVER
        bool "Install server"
        default y
index 99adf6afaf29f54bbdb5dabe58b113cb5f438db8..723ce9c02be88a7fe146bec596077acf971581c6 100644 (file)
@@ -17,7 +17,7 @@ KISMET_DEPENDENCIES = \
        zlib
 KISMET_LICENSE = GPL-2.0+
 KISMET_LICENSE_FILES = LICENSE
-KISMET_CONF_OPTS = --disable-debuglibs --disable-python-tools
+KISMET_CONF_OPTS = --disable-debuglibs
 
 KISMET_CXXFLAGS = $(TARGET_CXXFLAGS)
 
@@ -55,6 +55,15 @@ else
 KISMET_CONF_OPTS += --disable-pcre
 endif
 
+ifeq ($(BR2_PACKAGE_KISMET_PYTHON_TOOLS),y)
+KISMET_DEPENDENCIES += python3 python-setuptools
+KISMET_CONF_OPTS += \
+       --enable-python-tools \
+       --with-python-interpreter=$(HOST_DIR)/bin/python$(PYTHON3_VERSION_MAJOR)
+else
+KISMET_CONF_OPTS += --disable-python-tools
+endif
+
 KISMET_INSTALL_TARGET_OPTS += \
        DESTDIR=$(TARGET_DIR) \
        INSTUSR=$(shell id -u) \