alsa-utils: force the variant of ncurses library
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 18 Feb 2010 18:08:41 +0000 (19:08 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 18 Feb 2010 18:08:41 +0000 (19:08 +0100)
Two variants of the ncurses library exist: the normal one, and the
ncursesw one, which has support for wide char. Currently, Buildroot
only builds the normal variant (the second variant requires
--enable-widec while compiling ncurses).

Unfortunately, when libncursesw is installed on the host, the
configure script of alsa-utils finds /usr/bin/ncursesw5-config and
thinks that the target has this version. Unfortunately, as this is not
the case, it causes a configure failure when trying to link a sample
program against libpanelw (which is part of ncurses).

Therefore, we force the libncurses variant used by alsa-utils to the
normal variant.

Later on, if needed, support for the wide-char variant of the
libncurses library could be added.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/multimedia/alsa-utils/alsa-utils.mk

index f98b9cd02af943d156879282aaed93a9fbf92540..99d85ce01b3decb717c2e361bab5789d751331a4 100644 (file)
@@ -39,6 +39,7 @@ $(ALSA_UTILS_DIR)/.configured: $(ALSA_UTILS_DIR)/.unpacked
                --prefix=/usr \
                $(ALSA_UTILS_CONFIGURE_OPTS) \
                --disable-xmlto \
+               --with-curses=ncurses \
        )
        touch $@