package/vlc: add optional dependency to mpg123
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:33 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 11:36:53 +0000 (13:36 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index af500cba33fb093eea340eabc25e5ba5771b3a99..3dbaac17570b6dc34475e9bb5a14b5e9066a4937 100644 (file)
@@ -68,7 +68,6 @@ VLC_CONF_OPTS += \
        --disable-mfx \
        --disable-microdns \
        --disable-mmal \
-       --disable-mpg123 \
        --disable-mtp \
        --disable-notify \
        --disable-projectm \
@@ -453,6 +452,13 @@ ifeq ($(BR2_PACKAGE_MINIZIP),y)
 VLC_DEPENDENCIES += minizip
 endif
 
+ifeq ($(BR2_PACKAGE_MPG123),y)
+VLC_CONF_OPTS += --enable-mpg123
+VLC_DEPENDENCIES += mpg123
+else
+VLC_CONF_OPTS += --disable-mpg123
+endif
+
 ifeq ($(BR2_PACKAGE_MUSEPACK),y)
 VLC_CONF_OPTS += --enable-mpc
 VLC_DEPENDENCIES += musepack