mosh: bump to version 1.2.6
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 23 Aug 2016 14:26:09 +0000 (11:26 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Aug 2016 15:59:06 +0000 (17:59 +0200)
Now supports nettle as crypto backend too.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mosh/Config.in
package/mosh/mosh.hash
package/mosh/mosh.mk

index b4189ee10dd6adbc25eeff367216ad656bb30679..d1fbd632eb7c224d3dc10af0fb5c965d3666563f 100644 (file)
@@ -12,7 +12,7 @@ config BR2_PACKAGE_MOSH
        depends on BR2_USE_WCHAR
        select BR2_PACKAGE_PROTOBUF
        select BR2_PACKAGE_NCURSES
-       select BR2_PACKAGE_OPENSSL
+       select BR2_PACKAGE_NETTLE if !BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_ZLIB
        # runtime dependency
        select BR2_PACKAGE_OPENSSH if !BR2_PACKAGE_DROPBEAR_CLIENT
index ab925b5126b723f3cf52f890c5f622bb83ce0844..31f59c7f5e6864c13b21ebe666a5f5efdad0fbce 100644 (file)
@@ -1,2 +1,2 @@
-# From: http://mailman.mit.edu/pipermail/mosh-users/2015-July/000283.html
-sha256 1af809e5d747c333a852fbf7acdbf4d354dc4bbc2839e3afe5cf798190074be3 mosh-1.2.5.tar.gz
+# From https://mailman.mit.edu/pipermail/mosh-users/2016-August/000330.html
+sha256 7e82b7fbfcc698c70f5843bb960dadb8e7bd7ac1d4d2151c9d979372ea850e85 mosh-1.2.6.tar.gz
index f8c45e8ccd2abc684664a6e7346f4acba2bb6258..2cd358b39745b842c0d42af0122a7ff41391946a 100644 (file)
@@ -4,12 +4,20 @@
 #
 ################################################################################
 
-MOSH_VERSION = 1.2.5
+MOSH_VERSION = 1.2.6
 MOSH_SITE = https://mosh.mit.edu
-MOSH_DEPENDENCIES = zlib ncurses protobuf openssl host-pkgconf
+MOSH_DEPENDENCIES = zlib ncurses protobuf host-pkgconf
 MOSH_LICENSE = GPLv3+ with exception
 MOSH_LICENSE_FILES = COPYING COPYING.iOS
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+MOSH_CONF_OPTS += --with-crypto-library=openssl
+MOSH_DEPENDENCIES += openssl
+else
+MOSH_CONF_OPTS += --with-crypto-library=nettle
+MOSH_DEPENDENCIES += nettle
+endif
+
 # help the detection of the SSP support: mosh configure.ac doesn't do
 # a link test, so it doesn't detect when the toolchain doesn't have
 # libssp.