package/kodi: add support for libudev
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 11 Jul 2016 18:08:59 +0000 (20:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 17 Jul 2016 12:29:23 +0000 (14:29 +0200)
Most of the times this is not needed because libdrm & mesa3d already
pull in the dependency to udev. Let's add it anyway to make sure that
udev is really used and to document that Kodi makes use of udev.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kodi/kodi.mk

index da5d1fa75a1969b408c585335d373085555e2c74..e2919470212ec160800c69149a72f8553d3efe05 100644 (file)
@@ -102,6 +102,13 @@ KODI_CONF_ENV += INCLUDES="-I$(STAGING_DIR)/usr/include/interface/vcos/pthreads
        LIBS="-lvcos -lvchostif"
 endif
 
+ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
+KODI_DEPENDENCIES += udev
+KODI_CONF_OPTS += --enable-udev
+else
+KODI_CONF_OPTS += --disable-udev
+endif
+
 ifeq ($(BR2_PACKAGE_IMX_VPUWRAP),y)
 KODI_DEPENDENCIES += imx-vpuwrap
 KODI_CONF_OPTS += --enable-codec=imxvpu