qt5webengine: use QT5WEBENGINE prefix for CHROMIUM_LICENSE_FILES variable
authorLaurent Hartanerot <laurent.hartanerot@atos.net>
Thu, 30 Aug 2018 10:07:03 +0000 (12:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 1 Sep 2018 12:45:22 +0000 (14:45 +0200)
The qt5webengine package currently uses the CHROMIUM_LICENSE_FILES
variable to hold the list of license files for the chromium source
code embedded inside the qt5webengine code.

However, using this variable would clash with a hypothetical
"chromium" package, and anyway violates our rule that all variables of
a package should be prefixed by the package name.

This commit fixes that by adding the QT5WEBENGINE to this variable.

Signed-off-by: Laurent Hartanerot <laurent.hartanerot@atos.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/qt5webengine/chromium-latest.inc
package/qt5/qt5webengine/chromium-lts.inc
package/qt5/qt5webengine/qt5webengine.mk

index 3e98052b3808603170af5722dca01fd3d6cdc525..671b2383a3daa91ef23153d8c058ede2c6e4b0fb 100644 (file)
@@ -1,4 +1,4 @@
-CHROMIUM_LICENSE_FILES = \
+QT5WEBENGINE_CHROMIUM_LICENSE_FILES = \
        src/3rdparty/chromium/url/third_party/mozilla/LICENSE.txt \
        src/3rdparty/chromium/tools/symsrc/COPYING-pefile \
        src/3rdparty/chromium/tools/win/ChromeDebug/ChromeDebug/LICENSE \
index bff79316560ac4df194afb3b055aaa0743d1e7f0..d45e9692de213a48540a28a284b8ce78261c20da 100644 (file)
@@ -1,4 +1,4 @@
-CHROMIUM_LICENSE_FILES = \
+QT5WEBENGINE_CHROMIUM_LICENSE_FILES = \
        src/3rdparty/chromium/url/third_party/mozilla/LICENSE.txt \
        src/3rdparty/chromium/sdch/open-vcdiff/COPYING \
        src/3rdparty/chromium/tools/gyp/LICENSE \
index c4ae961126fd234cc5093524d8c38048eab4e123..a3cfcec26e956ed9658ca1541a6c820e948dc301 100644 (file)
@@ -19,7 +19,7 @@ include package/qt5/qt5webengine/chromium-lts.inc
 endif
 QT5WEBENGINE_LICENSE = GPL-2.0 or LGPL-3.0 or GPL-3.0 or GPL-3.0 with exception
 QT5WEBENGINE_LICENSE_FILES = LICENSE.GPL2 LICENSE.GPL3 LICENSE.GPL3-EXCEPT \
-       LICENSE.GPLv3 LICENSE.LGPL3 $(CHROMIUM_LICENSE_FILES)
+       LICENSE.GPLv3 LICENSE.LGPL3 $(QT5WEBENGINE_CHROMIUM_LICENSE_FILES)
 
 ifeq ($(BR2_PACKAGE_QT5BASE_XCB),y)
 QT5WEBENGINE_DEPENDENCIES += xlib_libXScrnSaver xlib_libXcomposite \