package/qt5/qt5base: add -syslog option
authorJeff Zignego <jzignego@hedcontrols.com>
Wed, 4 Nov 2020 18:12:21 +0000 (12:12 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 7 Nov 2020 13:46:22 +0000 (14:46 +0100)
QT can default to outputting the logs to syslog instead of to the
console with this compile time switch. That behavior can still be
overridden by setting the environment variable QT_LOGGING_TO_CONSOLE to
1.

Signed-off-by: Jeff Zignego <jzignego@hedcontrols.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/qt5base/Config.in
package/qt5/qt5base/qt5base.mk

index ce7230c72898cde92f8a3e830bfa65db1f87aff4..ee7c757c60f05be2b7273d7e387f38e01823da68 100644 (file)
@@ -263,6 +263,11 @@ config BR2_PACKAGE_QT5BASE_PNG
 
 endif
 
+config BR2_PACKAGE_QT5BASE_SYSLOG
+       bool "syslog support"
+       help
+         Logs to the standard UNIX logging mechanism.
+
 config BR2_PACKAGE_QT5BASE_DBUS
        bool "DBus module"
        depends on BR2_TOOLCHAIN_HAS_THREADS
index ed308c1fa2ffff1d384829cf86ea8c5ab74f656f..fa9262573851d5200d60652b38c8290f28ec2b87 100644 (file)
@@ -254,6 +254,12 @@ else
 QT5BASE_CONFIGURE_OPTS += -no-journald
 endif
 
+ifeq ($(BR2_PACKAGE_QT5BASE_SYSLOG),y)
+QT5BASE_CONIGURE_OPTS += -syslog
+else
+QT5BASE_CONFIGURE_OPTS += -no-syslog
+endif
+
 ifeq ($(BR2_PACKAGE_IMX_GPU_VIV),y)
 # use vivante backend
 QT5BASE_EGLFS_DEVICE = EGLFS_DEVICE_INTEGRATION = eglfs_viv