package/p11-kit: libffi is optional, not mandatory
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 21 Dec 2020 12:36:17 +0000 (13:36 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 29 Dec 2020 19:57:46 +0000 (20:57 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/p11-kit/Config.in
package/p11-kit/p11-kit.mk

index a6b72618866c6b5e76f1f8b2945a259d2b118b21..56904187566a215581f3e010b041e0c2b18c79fc 100644 (file)
@@ -3,7 +3,6 @@ config BR2_PACKAGE_P11_KIT
        depends on !BR2_STATIC_LIBS
        depends on BR2_USE_MMU
        depends on BR2_TOOLCHAIN_HAS_THREADS
-       select BR2_PACKAGE_LIBFFI
        select BR2_PACKAGE_LIBTASN1
        help
          Provides a way to load and enumerate PKCS#11 modules.
index 1f72e0515b10c8a32c8b9b99c968b3f1d9e283e1..fef479183166efb1a9b14241238df8dea8bf96e0 100644 (file)
@@ -6,7 +6,7 @@
 
 P11_KIT_VERSION = 0.23.16.1
 P11_KIT_SITE = https://github.com/p11-glue/p11-kit/releases/download/$(P11_KIT_VERSION)
-P11_KIT_DEPENDENCIES = host-pkgconf libffi libtasn1
+P11_KIT_DEPENDENCIES = host-pkgconf libtasn1
 P11_KIT_INSTALL_STAGING = YES
 P11_KIT_CONF_OPTS = --disable-static
 P11_KIT_CONF_ENV = ac_cv_have_decl_program_invocation_short_name=yes \
@@ -20,4 +20,11 @@ else
 P11_KIT_CONF_OPTS += --without-trust-paths
 endif
 
+ifeq ($(BR2_PACKAGE_LIBFFI),y)
+P11_KIT_DEPENDENCIES += host-pkgconf libffi
+P11_KIT_CONF_OPTS += --with-libffi
+else
+P11_KIT_CONF_OPTS += --without-libffi
+endif
+
 $(eval $(autotools-package))