package/alure: add flac decoder option
authorRomain Naour <romain.naour@gmail.com>
Sun, 5 Jan 2020 11:32:00 +0000 (12:32 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Jan 2020 20:21:02 +0000 (21:21 +0100)
Alure doesn't use/need flac package as dependency.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/alure/Config.in
package/alure/alure.mk

index 4acd66d2ee18d4f14777c09bcc65354effe8c4bf..df86ff2a92ed6219b77443c27bd7976ef9ed7aa5 100644 (file)
@@ -16,6 +16,15 @@ config BR2_PACKAGE_ALURE
 
          https://kcat.strangesoft.net/alure.html
 
+if BR2_PACKAGE_ALURE
+
+config BR2_PACKAGE_ALURE_FLAC_DECODER
+       bool "flac decoder"
+       help
+         Enables the built-in FLAC decoder.
+
+endif
+
 comment "alure needs a toolchain w/ C++, gcc >= 4.9, NPTL, wchar"
        depends on BR2_PACKAGE_OPENAL_ARCH_SUPPORTS
        depends on !BR2_INSTALL_LIBSTDCPP \
index efb0c4ccc37a89e9759cd004b2f75dd5acc636a4..afcc333683141e24c399af37c90a61115289d681 100644 (file)
@@ -16,13 +16,18 @@ ALURE_DEPENDENCIES = openal
 # Enable at least one built-in decoder (wave).
 ALURE_CONF_OPTS = -DALURE_INSTALL=ON \
        -DALURE_BUILD_EXAMPLES=OFF \
-       -DALURE_ENABLE_FLAC=OFF \
        -DALURE_ENABLE_MINIMP3=OFF \
        -DALURE_ENABLE_OPUS=OFF \
        -DALURE_ENABLE_SNDFILE=OFF \
        -DALURE_ENABLE_VORBIS=OFF \
        -DALURE_ENABLE_WAVE=ON
 
+ifeq ($(BR2_PACKAGE_ALURE_FLAC_DECODER),y)
+ALURE_CONF_OPTS += -DALURE_ENABLE_FLAC=ON
+else
+ALURE_CONF_OPTS += -DALURE_ENABLE_FLAC=OFF
+endif
+
 ifeq ($(BR2_STATIC_LIBS),y)
 ALURE_CONF_OPTS += -DALURE_BUILD_SHARED=OFF \
        -DALURE_BUILD_STATIC=ON