package/grep: install to /bin to fix busybox aliasing
authorAngelo Compagnucci <angelo@amarulasolutions.com>
Tue, 4 Feb 2020 13:14:41 +0000 (14:14 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Feb 2020 14:23:22 +0000 (15:23 +0100)
When the grep package is selected, it should be installed at the same exact
location where busybox installs it too, this way the grep/egrep/fgrep
executables will end up overwriting the busybox provided ones.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/grep/grep.mk

index 96685b0276c9d44c4180e600050c650c018a0672..eefdfe6a74a86fa352d29d2246aaaa1b7482dd80 100644 (file)
@@ -10,6 +10,8 @@ GREP_SOURCE = grep-$(GREP_VERSION).tar.xz
 GREP_LICENSE = GPL-3.0+
 GREP_LICENSE_FILES = COPYING
 GREP_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
+# install into /bin like busybox grep
+GREP_CONF_OPTS = --exec-prefix=/
 
 # link with iconv if enabled
 ifeq ($(BR2_PACKAGE_LIBICONV),y)