package/meson: bump version to 0.53.2
authorAdam Duskett <Aduskett@gmail.com>
Wed, 26 Feb 2020 14:30:07 +0000 (06:30 -0800)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 26 Feb 2020 18:00:04 +0000 (19:00 +0100)
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/meson/0001-Only-fix-RPATH-if-install_rpath-is-not-empty.patch
package/meson/0002-Prefer-ext-static-libs-when-default-library-static.patch
package/meson/0003-envconfig-add-pkg_config_libdir-property.patch
package/meson/meson.hash
package/meson/meson.mk

index a7b66c10674cbb37539c5652441de51caeed8a7d..79e99adf4aeb135204c22f7ec046fdbddb6ac415 100644 (file)
@@ -14,7 +14,7 @@ diff --git a/mesonbuild/minstall.py b/mesonbuild/minstall.py
 index 8ac6aab1..7ef04116 100644
 --- a/mesonbuild/minstall.py
 +++ b/mesonbuild/minstall.py
-@@ -478,8 +478,14 @@ class Installer:
+@@ -489,8 +489,14 @@ class Installer:
                          printed_symlink_error = True
              if os.path.isfile(outname):
                  try:
index 798cd65299aa2990817a0064c2b387f5a4a3ddce..b859d8372e99355102be31b711868d38009efd1c 100644 (file)
@@ -30,7 +30,7 @@ diff --git a/mesonbuild/compilers/mixins/clike.py b/mesonbuild/compilers/mixins/
 index 5d50b7d..8f5f1c6 100644
 --- a/mesonbuild/compilers/mixins/clike.py
 +++ b/mesonbuild/compilers/mixins/clike.py
-@@ -858,6 +858,9 @@ class CLikeCompiler:
+@@ -857,6 +857,9 @@ class CLikeCompiler:
          elif env.machines[self.for_machine].is_cygwin():
              shlibext = ['dll', 'dll.a']
              prefixes = ['cyg'] + prefixes
index ae40ab8b1c05a7c1dca54b7bac7bfdf8a3364cd6..8ae34b999da54ba33eeada514042631e20ada69f 100644 (file)
@@ -53,7 +53,7 @@ diff --git a/run_unittests.py b/run_unittests.py
 index 676604f4..382c0964 100755
 --- a/run_unittests.py
 +++ b/run_unittests.py
-@@ -3621,6 +3621,34 @@ recommended as it is not supported on some platforms''')
+@@ -3629,6 +3629,34 @@ recommended as it is not supported on some platforms''')
          self.wipe()
          self.init(testdir, extra_args=['-Dstart_native=true'], override_envvars=env)
  
@@ -88,7 +88,7 @@ index 676604f4..382c0964 100755
      def __reconfigure(self, change_minor=False):
          # Set an older version to force a reconfigure from scratch
          filename = os.path.join(self.privatedir, 'coredata.dat')
-@@ -6847,7 +6875,7 @@ class NativeFileTests(BasePlatformTests):
+@@ -6863,7 +6891,7 @@ class NativeFileTests(BasePlatformTests):
  
  class CrossFileTests(BasePlatformTests):
  
index 881d4211cf281fa0136f6acb4b156f5019c24658..3777a515429a3e1d5b3e0b81e8553e18a5507a57 100644 (file)
@@ -1,4 +1,4 @@
 # Locally calculated after checking pgp signature
-# https://github.com/mesonbuild/meson/releases/download/0.53.1/meson-0.53.1.tar.gz.asc
-sha256 ec1ba33eea701baca2c1607dac458152dc8323364a51fdef6babda2623413b04 meson-0.53.1.tar.gz
+# https://github.com/mesonbuild/meson/releases/download/0.53.2/meson-0.53.2.tar.gz.asc
+sha256 3e8f830f33184397c2eb0b651ec502adb63decb28978bdc84b3558d71284c21f meson-0.53.2.tar.gz
 sha256 cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30 COPYING
index 810c84690ad719b9d73d8c368298a8a53968b216..29c7ed180059c8862b9592e096c71bfca57756b1 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-MESON_VERSION = 0.53.1
+MESON_VERSION = 0.53.2
 MESON_SITE = https://github.com/mesonbuild/meson/releases/download/$(MESON_VERSION)
 MESON_LICENSE = Apache-2.0
 MESON_LICENSE_FILES = COPYING