package/bullet: bump to version 2.85.1
authorRomain Naour <romain.naour@gmail.com>
Sat, 24 Dec 2016 11:37:39 +0000 (12:37 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 25 Dec 2016 22:13:32 +0000 (23:13 +0100)
http://bulletphysics.org/wordpress/?p=456

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/bullet/bullet.hash
package/bullet/bullet.mk

index 5b5360c62146d5bafdd107bcdde86c947c40e47f..cccc42580e1ee5faa3bc8b5f6fd5c3d1062ee28e 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 c26ac96b487d7e44136ff4406dbbfe5a4d7d254ed1a2c09122c464803e7d1314  bullet-19f999ac087e68ffc2551ffb73e35e60271a0d27.tar.gz
+sha256 6e157c0b50373bc0e860de27f06397827bb28a4205bc568ae79d76a0f919ed62  bullet-2.85.1.tar.gz
index 3ec97b4326853265dfd460f192484b7f4af9179f..99ff423632babd3a4507e61c9f93eda42feaa2e0 100644 (file)
@@ -4,15 +4,16 @@
 #
 ################################################################################
 
-# This is the git id of the 2.82 release.
-BULLET_VERSION = 19f999ac087e68ffc2551ffb73e35e60271a0d27
+BULLET_VERSION = 2.85.1
 BULLET_SITE = $(call github,bulletphysics,bullet3,$(BULLET_VERSION))
 BULLET_INSTALL_STAGING = YES
 BULLET_LICENSE = zlib license
-BULLET_LICENSE_FILES = BulletLicense.txt COPYING
+BULLET_LICENSE_FILES = LICENSE.txt
 
-# Disable GLUT support since there is no freeglut or OpenGLUT package and we
-# don't build the demos apps.
-BULLET_CONF_OPTS = -DUSE_GLUT=OFF -DBUILD_DEMOS=OFF
+# Disable demos apps and unit tests.
+# Disable Bullet3 library.
+BULLET_CONF_OPTS = -DBUILD_UNIT_TESTS=OFF \
+       -DBUILD_BULLET2_DEMOS=OFF \
+       -DBUILD_BULLET3=OFF
 
 $(eval $(cmake-package))