package/fftw: disable fortran
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 16 Mar 2015 16:31:24 +0000 (17:31 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 16 Mar 2015 18:44:02 +0000 (19:44 +0100)
We do not have any fortran package and we do not build a fortran
compiler.

Still, an external toolchain may have a fortran compiler and that is
totally useless to us, since we anyway have no fortran package...

So, entirely disable fortran support; that will at least slightly speed
up the build in case an external toolchain has a fortran compiler.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
[based on a patch by Guillaume]
Cc: guillaume william brs <guillaume.bressaix@gmail.com>
Cc: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Tested-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Reviewed-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/fftw/fftw.mk

index 154f522ea343c987ebcf5b5bddd59b71878e1dce..3acde57ca3068e5d35c4b96987b13e5ba2e23dc9 100644 (file)
@@ -10,6 +10,8 @@ FFTW_INSTALL_STAGING = YES
 FFTW_LICENSE = GPLv2+
 FFTW_LICENSE_FILES = COPYING
 
+FFTW_CONF_OPTS = --disable-fortran
+
 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_PRECISION_SINGLE),--enable,--disable)-single
 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE),--enable,--disable)-long-double
 FFTW_CONF_OPTS += $(if $(BR2_PACKAGE_FFTW_PRECISION_QUAD),--enable,--disable)-quad-precision