package/libmediaart: enable gobject-introspection support
authorAdam Duskett <Aduskett@gmail.com>
Wed, 1 Apr 2020 00:21:32 +0000 (17:21 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 20:35:41 +0000 (22:35 +0200)
If gobject-introspection is selected, add the gobject-introspection package to
the dependency list and set the conf opt --enable-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libmediaart/libmediaart.mk

index 4933b74c190dc3e1413a1bc4fa6f1e8ebbab4ae5..0d110a43e566d5b589cdd895b26df26e7756dad7 100644 (file)
@@ -33,4 +33,11 @@ LIBMEDIAART_CONF_OPTS += \
        --disable-qt
 endif
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+LIBMEDIAART_CONF_OPTS += --enable-introspection
+LIBMEDIAART_DEPENDENCIES += gobject-introspection
+else
+LIBMEDIAART_CONF_OPTS += --disable-introspection
+endif
+
 $(eval $(autotools-package))