make: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:58:33 +0000 (22:58 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:28:45 +0000 (01:28 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/make/Config.in
package/make/make.mk

index f576b7b5a33580227d180b14d85640009c6affec..e8aa912ff694d1b544f9836b9ec46cdbcbb85f0d 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_MAKE
        bool "make"
        depends on BR2_USE_MMU # fork()
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          A tool which controls the generation of executables and other
          non-source files of a program from the program's source files.
index 41a7023a25740b19ffa9223e817ba621a63a4156..5717628fa3e95c9cbafacf4dd120d8fbea5dc6cf 100644 (file)
@@ -7,7 +7,7 @@
 MAKE_VERSION = 4.2.1
 MAKE_SOURCE = make-$(MAKE_VERSION).tar.bz2
 MAKE_SITE = $(BR2_GNU_MIRROR)/make
-MAKE_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
+MAKE_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
 MAKE_LICENSE = GPL-3.0+
 MAKE_LICENSE_FILES = COPYING