sdl_gfx: new package
authorEvan Zelkowitz <evan.zelkowitz@gmail.com>
Sat, 18 Jul 2009 09:29:26 +0000 (11:29 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 18 Jul 2009 09:30:12 +0000 (11:30 +0200)
Closes #369.

[Peter: Minor tweaks]

Signed-off-by: Evan Zelkowitz <evan.zelkowitz@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/Config.in
package/sdl_gfx/Config.in [new file with mode: 0644]
package/sdl_gfx/sdl_gfx.mk [new file with mode: 0644]

diff --git a/CHANGES b/CHANGES
index 61a79b9be058ce6c63de84febc0d4cc8ae7822dc..781f5cfd1064550f33a36780b3730fc77fe307a5 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -9,6 +9,7 @@
        #349: update libsoup to version 2.26.2
        #359,#413: Upgrade openvpn to Makefile.autotools.in
        #367: linux kernel compile error for arm926t
+       #369: Add SDL_gfx package
        #373: Support for building gstreamer without libxml
        #379: update DirectFB to version 1.4.0
        #383: gst-plugins-good: Allow soup plugin to be configured
index cb83563119547e7226f3524959f8886924cba353..4a943a869fcab584aa923953584582212652f71c 100644 (file)
@@ -306,6 +306,7 @@ source "package/sdl_image/Config.in"
 source "package/sdl_mixer/Config.in"
 source "package/sdl_net/Config.in"
 source "package/sdl_ttf/Config.in"
+source "package/sdl_gfx/Config.in"
 source "package/tiff/Config.in"
 
 comment "busybox graphic applications"
diff --git a/package/sdl_gfx/Config.in b/package/sdl_gfx/Config.in
new file mode 100644 (file)
index 0000000..4910b2d
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_SDL_GFX
+       bool "SDL_gfx"
+       depends on BR2_PACKAGE_SDL
+       help
+         The SDL_gfx library is an extension to the SDL library which
+         provides basic antialiased drawing routines such as lines,
+         circles or polygons, an interpolating rotozoomer for SDL
+         surfaces, framerate control and MMX image filters.
+
+         http://www.ferzkopp.net/joomla/content/view/19/14/
diff --git a/package/sdl_gfx/sdl_gfx.mk b/package/sdl_gfx/sdl_gfx.mk
new file mode 100644 (file)
index 0000000..bd4e3f1
--- /dev/null
@@ -0,0 +1,26 @@
+#############################################################
+#
+# SDL_gfx addon for SDL
+#
+#############################################################
+SDL_GFX_VERSION:=2.0.19
+SDL_GFX_SOURCE:=SDL_gfx-$(SDL_GFX_VERSION).tar.gz
+SDL_GFX_SITE:=http://www.ferzkopp.net/Software/SDL_gfx-2.0/
+SDL_GFX_LIBTOOL_PATCH:=NO
+SDL_GFX_INSTALL_STAGING:=YES
+SDL_GFX_INSTALL_TARGET:=YES
+
+SDL_GFX_DEPENDENCIES:=sdl
+
+SDL_GFX_CONF_OPT:=--with-sdl-prefix=$(STAGING_DIR)/usr \
+               --disable-sdltest \
+               --enable-static
+
+# enable mmx for newer x86's
+ifeq ($(BR2_i386)$(BR2_x86_i386)$(BR2_x86_i486)$(BR2_x86_i586)$(BR2_x86_pentiumpro)$(BR2_x86_geode),y)
+SDL_GFX_CONF_OPT += --enable-mmx
+else
+SDL_GFX_CONF_OPT += --disable-mmx
+endif
+
+$(eval $(call AUTOTARGETS,package,sdl_gfx))