qt: enable proper re-configure
authorMichael Roth <mroth@nessie.de>
Wed, 7 Oct 2009 09:20:26 +0000 (11:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 9 Oct 2009 12:35:23 +0000 (14:35 +0200)
The Qt configure script doesn't use config.cache but the
generated Makefile provides a confclean target to properly
clean out old configuration.

Signed-off-by: Michael Roth <mroth@nessie.de>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/qt.mk

index 68b4e441d28ccdddd6ba1e896e58740f5e1b52a7..5b9906e9b5cb73ec2157bdd8bcfcb433a8ab0974 100644 (file)
@@ -426,6 +426,7 @@ $(QT_TARGET_DIR)/.unpacked: $(DL_DIR)/$(QT_SOURCE)
        touch $@
 
 $(QT_TARGET_DIR)/.configured: $(QT_TARGET_DIR)/.unpacked
+       -[ -f $(QT_TARGET_DIR)/Makefile ] && $(MAKE) -C $(QT_TARGET_DIR) confclean
 ifneq ($(BR2_INET_IPV6),y)
        $(SED) 's/^CFG_IPV6=auto/CFG_IPV6=no/' $(QT_TARGET_DIR)/configure
        $(SED) 's/^CFG_IPV6IFNAME=auto/CFG_IPV6IFNAME=no/' $(QT_TARGET_DIR)/configure
@@ -450,7 +451,7 @@ endif
 # when cross compiling, Qt 4.4.3 is wrong here.
 # Don't use TARGET_CONFIGURE_OPTS here, qmake would be compiled for the target
 # instead of the host then.
-       (cd $(QT_TARGET_DIR); rm -rf config.cache; \
+       (cd $(QT_TARGET_DIR); \
                PATH=$(TARGET_PATH) \
                PKG_CONFIG_SYSROOT_DIR="$(STAGING_DIR)" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig:$(PKG_CONFIG_PATH)" \