libsrtp: new package
authorGregory Dymarek <gregd72002@gmail.com>
Fri, 12 Dec 2014 15:42:44 +0000 (15:42 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 1 Jan 2015 10:22:52 +0000 (11:22 +0100)
[Thomas:
 - Add better Config.in help text and fix its indentation
 - Fix comment header in .mk file
 - Uncomment useful commented lines in .mk file (SITE and AUTORECONF)
 - Add LICENSE_FILES variable.
 - Add handling of static/shared libraries build/installation.
 - Add dependency on host-pkgconf, so that libsrtp installs its own
   .pc file.
 - Add optional dependency on OpenSSL.
 - Use github helper.
 - Remove hash file, since we're downloading from Git.]

Signed-off-by: Gregory Dymarek <gregd72002@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libsrtp/Config.in [new file with mode: 0644]
package/libsrtp/libsrtp.mk [new file with mode: 0644]

index ae6ffd7f009d12d1f7a7c46d0e4aa63741e7f4db..78aa842e3c258472f9b43f1914c8f18adf92765c 100644 (file)
@@ -846,6 +846,7 @@ menu "Networking"
        source "package/libshout/Config.in"
        source "package/libsocketcan/Config.in"
        source "package/libsoup/Config.in"
+       source "package/libsrtp/Config.in"
        source "package/libstrophe/Config.in"
        source "package/libtirpc/Config.in"
        source "package/libtorrent/Config.in"
diff --git a/package/libsrtp/Config.in b/package/libsrtp/Config.in
new file mode 100644 (file)
index 0000000..ce37712
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBSRTP
+       bool "libsrtp"
+       help
+         This package provides an implementation of the Secure
+         Real-time Transport Protocol (SRTP), the Universal Security
+         Transform (UST), and a supporting cryptographic kernel.
+
+         https://github.com/cisco/libsrtp
diff --git a/package/libsrtp/libsrtp.mk b/package/libsrtp/libsrtp.mk
new file mode 100644 (file)
index 0000000..5e62255
--- /dev/null
@@ -0,0 +1,35 @@
+################################################################################
+#
+# libsrtp
+#
+################################################################################
+
+LIBSRTP_VERSION = v1.5.0
+LIBSRTP_SITE = $(call github,cisco,libsrtp,$(LIBSRTP_VERSION))
+LIBSRTP_AUTORECONF = YES
+LIBSRTP_INSTALL_STAGING = YES
+LIBSRTP_LICENSE = BSD-3c
+LIBSRTP_LICENSE_FILES = LICENSE
+
+ifeq ($(BR2_STATIC_LIBS),y)
+LIBSRTP_MAKE_OPTS = libsrtp.a
+else ifeq ($(BR2_SHARED_LIBS),y)
+LIBSRTP_MAKE_OPTS = shared_library
+else
+LIBSRTP_MAKE_OPTS = libsrtp.a shared_library
+endif
+
+# While libsrtp is not using pkg-config itself, it checks if
+# pkg-config is available to determine whether it should install
+# libsrtp.pc. Since installing it seems useful, let's depend on
+# host-pkgconf to make sure pkg-config is installed.
+LIBSRTP_DEPENDENCIES = host-pkgconf
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBSRTP_DEPENDENCIES += openssl
+LIBSRTP_CONF_OPTS += --enable-openssl
+else
+LIBSRTP_CONF_OPTS += --disable-openssl
+endif
+
+$(eval $(autotools-package))