ebtables: fix passing CFLAGS to configure
authorMax Filippov <jcmvbkbc@gmail.com>
Mon, 12 May 2014 03:27:05 +0000 (07:27 +0400)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 12 May 2014 20:49:16 +0000 (22:49 +0200)
EBTABLES_K64U32 is a string passed directly to the configure script,
'+=' operator doesn't have any special meaningi inside it, so
CFLAGS+=-DKERNEL_64_USERSPACE_32 is passed to shell, overwriting previous
CFLAGS value.

Replace CFLAGS+="-DKERNEL_64_USERSPACE_32" with -DKERNEL_64_USERSPACE_32
and pass CFLAGS="$(TARGET_CFLAGS) $(EBTABLES_K64U32)".

Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ebtables/ebtables.mk

index 66a47a2d906d7888ff61c6570fab082cfb5abebf..578c3ae805a03d718065f0394d793c1ec9adb6e3 100644 (file)
@@ -10,11 +10,11 @@ EBTABLES_SITE = http://downloads.sourceforge.net/project/ebtables/ebtables/ebtab
 EBTABLES_LICENSE = GPLv2+
 EBTABLES_LICENSE_FILES = COPYING
 EBTABLES_STATIC = $(if $(BR2_PREFER_STATIC_LIB),static)
-EBTABLES_K64U32 = $(if $(BR2_KERNEL_64_USERLAND_32),CFLAGS+="-DKERNEL_64_USERSPACE_32")
+EBTABLES_K64U32 = $(if $(BR2_KERNEL_64_USERLAND_32),-DKERNEL_64_USERSPACE_32)
 
 define EBTABLES_BUILD_CMDS
        $(MAKE) $(TARGET_CONFIGURE_OPTS) LIBDIR=/lib/ebtables $(EBTABLES_STATIC) \
-               $(EBTABLES_K64U32) -C $(@D)
+               CFLAGS="$(TARGET_CFLAGS) $(EBTABLES_K64U32)" -C $(@D)
 endef
 
 ifeq ($(BR2_PREFER_STATIC_LIB),y)