linux: generate KBUILD_BUILD_TIMESTAMP date whith LC_ALL=C
authorJean-Baptiste Trédez <jean-baptiste.tredez@basystemes.fr>
Wed, 7 Dec 2016 15:20:42 +0000 (16:20 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 7 Dec 2016 22:34:52 +0000 (23:34 +0100)
Fix kernel reproducible build if a non-C locale is used on the host
system.

When building the Linux kernel, scripts/gen_initramfs_list.sh does 'date
-d"$KBUILD_BUILD_TIMESTAMP" +%s'. In linux.mk, Buildroot sets
KBUILD_BUILD_TIMESTAMP to "$(shell date -d @$(SOURCE_DATE_EPOCH))".

For example, if LANG=fr_FR.UTF-8 is defined in the host system, it does
not work:

- LC_ALL=C date -d"$(LC_ALL=C date)" : ok
- LC_ALL=C date -d"$(LC_ALL=fr_FR.UTF-8 date)" : error

LANG/LC_ALL variables exported in the main Makefiles are not passed in
the $(shell ...) sub-shells.

Signed-off-by: Jean-Baptiste Trédez <jean-baptiste.tredez@basystemes.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk

index 7e826ccdf08bede14dd27bd72355e90781fe7898..e75dcaa60d7f51906d86d0c519f3004ad6ff9e8d 100644 (file)
@@ -99,7 +99,7 @@ LINUX_MAKE_ENV += \
        KBUILD_BUILD_VERSION=1 \
        KBUILD_BUILD_USER=buildroot \
        KBUILD_BUILD_HOST=buildroot \
-       KBUILD_BUILD_TIMESTAMP="$(shell date -d @$(SOURCE_DATE_EPOCH))"
+       KBUILD_BUILD_TIMESTAMP="$(shell LC_ALL=C date -d @$(SOURCE_DATE_EPOCH))"
 endif
 
 # Get the real Linux version, which tells us where kernel modules are