erlang: odbc support requires thread support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Dec 2016 21:44:56 +0000 (22:44 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Dec 2016 21:49:15 +0000 (22:49 +0100)
Fixes:

  http://autobuild.buildroot.net/results/cba60679fa916128796a7b4131ed50403bc74798/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/erlang/erlang.mk

index c9d7b22670cf1d345fc584296ba149a84f788997..3200c388fdece1935f41133fb23e7f9a1eb96447 100644 (file)
@@ -55,8 +55,12 @@ else
 ERLANG_CONF_OPTS += --without-ssl
 endif
 
-ifeq ($(BR2_PACKAGE_UNIXODBC),y)
+# ODBC support in erlang requires threads
+ifeq ($(BR2_PACKAGE_UNIXODBC)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
 ERLANG_DEPENDENCIES += unixodbc
+ERLANG_CONF_OPTS += --with-odbc
+else
+ERLANG_CONF_OPTS += --without-odbc
 endif
 
 ifeq ($(BR2_PACKAGE_ZLIB),y)