Merge branch 'next'
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 1 Jun 2017 20:28:14 +0000 (22:28 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 1 Jun 2017 20:28:14 +0000 (22:28 +0200)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
12 files changed:
1  2 
DEVELOPERS
package/Config.in
package/bluez_utils/Config.in
package/c-icap/c-icap.mk
package/gcc/Config.in.host
package/gcc/gcc.hash
package/libv4l/libv4l.mk
package/ltp-testsuite/ltp-testsuite.mk
package/mono/mono.mk
package/mosh/Config.in
package/redis/redis.mk
package/sudo/sudo.mk

diff --cc DEVELOPERS
Simple merge
Simple merge
Simple merge
index 7925f5bc3e2067ebaab2fcfb1009230eea64a98d,e57ecd0ae0f1996b57610dd5ffd6963e1cc011b0..c722098c593fbfa487f08377c853c5f17bb35f01
@@@ -36,12 -34,40 +34,40 @@@ C_ICAP_CONF_OPTS += --without-bd
  endif
  
  ifeq ($(BR2_PACKAGE_BZIP2),y)
 -C_ICAP_CONF_OPTS += --with-bzip2
 +C_ICAP_CONF_OPTS += --with-bzlib
  C_ICAP_DEPENDENCIES += bzip2
  else
 -C_ICAP_CONF_OPTS += --without-bzip2
 +C_ICAP_CONF_OPTS += --without-bzlib
  endif
  
+ ifeq ($(BR2_PACKAGE_LIBMEMCACHED),y)
+ C_ICAP_CONF_OPTS += --with-memcached
+ C_ICAP_DEPENDENCIES += libmemcached
+ else
+ C_ICAP_CONF_OPTS += --without-memcached
+ endif
+ ifeq ($(BR2_PACKAGE_OPENLDAP),y)
+ C_ICAP_CONF_OPTS += --with-ldap
+ C_ICAP_DEPENDENCIES += openldap
+ else
+ C_ICAP_CONF_OPTS += --without-ldap
+ endif
+ ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ C_ICAP_CONF_OPTS += --with-openssl
+ C_ICAP_DEPENDENCIES += openssl
+ else
+ C_ICAP_CONF_OPTS += --without-openssl
+ endif
+ ifeq ($(BR2_PACKAGE_PCRE),y)
+ C_ICAP_CONF_OPTS += --with-pcre
+ C_ICAP_DEPENDENCIES += pcre
+ else
+ C_ICAP_CONF_OPTS += --without-pcre
+ endif
  ifeq ($(BR2_PACKAGE_ZLIB),y)
  C_ICAP_CONF_OPTS += --with-zlib
  C_ICAP_DEPENDENCIES += zlib
index 5a0fd970b87b770dfc3dd1970e85d835418d060e,3e7fb807f95c8c32218bfd155ac834d0312cfde1..2b78b29d4ac9b4c4bacd6cd6e199f6654a168477
@@@ -105,8 -91,8 +91,8 @@@ config BR2_GCC_VERSIO
        default "4.9.4"     if BR2_GCC_VERSION_4_9_X
        default "5.4.0"     if BR2_GCC_VERSION_5_X
        default "6.3.0"     if BR2_GCC_VERSION_6_X
 -      default "arc-2017.03-rc1" if BR2_GCC_VERSION_ARC
+       default "7.1.0"     if BR2_GCC_VERSION_7_X
 +      default "arc-2017.03" if BR2_GCC_VERSION_ARC
        default "musl-5.4.0" if BR2_GCC_VERSION_OR1K
  
  config BR2_EXTRA_GCC_CONFIG_OPTIONS
index db59bae30995cb3f4cc0c29b17d857c44694bb9c,7a37bb6da1a1f42668081fe217804974cae24e1a..f64329b072cd87565fa0884eef8ac9da4354c2f0
@@@ -10,8 -4,10 +4,10 @@@ sha512  93abb78e16277454f41a8e9810f41f6
  sha512  2941cc950c8f2409a314df497631f9b0266211aa74746c1839c46e04f1c7c299afe2528d1ef16ea39def408a644ba48f97519ec7a7dd37d260c3e9423514265b  gcc-5.4.0.tar.bz2
  # From ftp://gcc.gnu.org/pub/gcc/releases/gcc-6.3.0/sha512.sum
  sha512  234dd9b1bdc9a9c6e352216a7ef4ccadc6c07f156006a59759c5e0e6a69f0abcdc14630eff11e3826dd6ba5933a8faa43043f3d1d62df6bd5ab1e82862f9bf78  gcc-6.3.0.tar.bz2
+ # From ftp://gcc.gnu.org/pub/gcc/releases/gcc-7.1.0/sha512.sum
+ sha512  b5d952be9a10f0e0926bb2868877d10544039d6d2f35ba0a08f51231dd622a007650764a03e173194701467547789ad7d2d9cbc10adcdf118d619cdedbd14aec  gcc-7.1.0.tar.bz2
  
  # Locally calculated (fetched from Github)
 -sha512  e4fe5a179b8feabf932a8a6f4794ff6907b868a65487412d855a4b3671aa24ec8544a44f3b63e69ea2c12fcd4d8028d0619d40bf016ee7c1a5b5a99aa9315ef3  gcc-arc-2017.03-rc1.tar.gz
 +sha512  282f76b8b63372f5b4426092b80d36da96cd0bda2a8588405b9ec22806c69fafb696b0e0df65bc36c3c3aa8ce5befc24246fd5c6ddb21dcde01f45f7b11ff7c4  gcc-arc-2017.03.tar.gz
  # Locally calculated (fetched from Github)
  sha512  841101f7de45f327bf2e92f3efc73ca88a021e4b9b541458ce80a16e55882bd8606a8492d75c57c589ee2c10d42ae2865b67690155d7289a541df1d68096402f  gcc-musl-5.4.0.tar.gz
Simple merge
Simple merge
index 18065201bc6ef7b8f23b834d96991a311ddff00a,96c3b94e8c2149c662b6a4a9847ba6ed4bdcc8a7..da8a305a06e88c6236052a73cf7d20b6defa38ad
@@@ -20,15 -20,8 +20,16 @@@ config BR2_PACKAGE_MOS
        # runtime dependency
        select BR2_PACKAGE_OPENSSH if !BR2_PACKAGE_DROPBEAR_CLIENT
        help
--        Remote terminal application that supports intermittent connectivity,
--        allows roaming, and provides speculative local echo and line editing
--        of user keystrokes.
++        Remote terminal application that supports intermittent
++        connectivity, allows roaming, and provides speculative local
++        echo and line editing of user keystrokes.
 +
-         Mosh requires that the remote machine has a locale setting matching
-         the one on the client.
++        Mosh requires that the remote machine has a locale setting
++        matching the one on the client.
 +
-         When using mosh with dropbear on a remote machine, the client needs mosh
-         with a version above 1.3.0 and the --no-ssh-pty option needs to be passed
-         when starting the connection.
++        When using mosh with dropbear on a remote machine, the
++        client needs mosh with a version above 1.3.0 and the
++        --no-ssh-pty option needs to be passed when starting the
++        connection.
  
-         https://mosh.mit.edu
+         https://mosh.org
Simple merge
Simple merge