gstreamer: add option to disable gst_debug tracing functionality
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 27 Sep 2011 09:52:50 +0000 (11:52 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 27 Sep 2011 09:54:20 +0000 (11:54 +0200)
Shrinks gst library sizes with ~1MB (depending on the amount of plugins
enabled).

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gstreamer/Config.in
package/multimedia/gstreamer/gstreamer.mk

index 7de904c8c9fb8763f2a9d041ce624c63077fc74e..4d279b8b1c105ded2828e229d7bc6366a5855fc7 100644 (file)
@@ -7,5 +7,14 @@ config BR2_PACKAGE_GSTREAMER
 
          http://gstreamer.freedesktop.org/
 
+config BR2_PACKAGE_GSTREAMER_GST_DEBUG
+       bool "enable gst-debug trace support"
+       default y
+       depends on BR2_PACKAGE_GSTREAMER
+       help
+         Enable support for the gst-debug tracing functionality
+         in gstreamer. This has limited CPU overhead, but does
+         increase the rootfs size somewhat.
+
 comment "gstreamer requires a toolchain with WCHAR support"
        depends on !BR2_USE_WCHAR
index db5ccaf6509d00598a2ea6f49ffee3fe6cf69d9e..ffc8745559861e1b0fac98979d302a9cb9ec1656 100644 (file)
@@ -1,3 +1,4 @@
+
 #############################################################
 #
 # gstreamer
@@ -19,7 +20,8 @@ GSTREAMER_CONF_OPT = \
                --disable-examples \
                --disable-tests \
                --disable-failing-tests \
-               --disable-loadsave
+               --disable-loadsave \
+               $(if $(BR2_PACKAGE_GSTREAMER_GST_DEBUG),,--disable-gst-debug)
 
 GSTREAMER_DEPENDENCIES = libglib2 host-pkg-config