package/psplash: bump to revision fd33a9b
authorPierre-Jean Texier <pjtexier@koncepto.io>
Wed, 26 Feb 2020 16:03:26 +0000 (17:03 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 26 Feb 2020 18:03:05 +0000 (19:03 +0100)
This includes the following changes:

66c8f65 Makefile.am: use BUILT_SOURCES instead of BUILD_SOURCES
f7a354d Generate image headers from their PNG source, while still including them in dist tarball
983837e Import png source for images, extracted from headers
3bd1557 Cleanup poky logo
773a397 Add configure flags for fullscreen logo and no startup message
2913c24 Double buffering support
8188d68 Support --with-font configure option to use other font headers
88c4b71 Add SPDX License information to files, drop boilerplate
904f4aa add systemd support
e94bd11 process consecutive commands
568f28e use /run for communication FIFO
ee053e0 add recovered bar.png
2015f70 Fix text width calculation.

Also:
 - remove the 'psplash-quit.service' unit file
 - add 'psplash-systemd.service' to use the new systemd support in psplash

Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/psplash/psplash-quit.service [deleted file]
package/psplash/psplash-start.service
package/psplash/psplash-systemd.service [new file with mode: 0644]
package/psplash/psplash.hash
package/psplash/psplash.mk

diff --git a/package/psplash/psplash-quit.service b/package/psplash/psplash-quit.service
deleted file mode 100644 (file)
index 14bd499..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Terminate Psplash Boot Screen
-After=psplash-start.service
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/psplash-write QUIT
-TimeoutSec=20
-
-[Install]
-WantedBy=multi-user.target
index 2de3cfce22a45fb92c9e5fcad23af2d751894e35..b97e883e5474bdb043dc4b434164c54a0a904563 100644 (file)
@@ -1,8 +1,7 @@
 [Unit]
 Description=Starts Psplash Boot screen
-Wants=systemd-vconsole-setup.service
-After=systemd-vconsole-setup.service systemd-udev-trigger.service systemd-udevd.service
 DefaultDependencies=no
+RequiresMountsFor=/run
 
 [Service]
 ExecStart=/usr/bin/psplash -n
diff --git a/package/psplash/psplash-systemd.service b/package/psplash/psplash-systemd.service
new file mode 100644 (file)
index 0000000..249aa54
--- /dev/null
@@ -0,0 +1,12 @@
+[Unit]
+Description=Start psplash-systemd progress communication helper
+DefaultDependencies=no
+After=systemd-start.service
+Requires=psplash-start.service
+RequiresMountsFor=/run
+
+[Service]
+ExecStart=/usr/bin/psplash-systemd
+
+[Install]
+WantedBy=sysinit.target
index c8865697c488acf7462f9ccc2b81f95282b8ca19..46d5e12cebf45cc21eb5b76866b1670238baa2f2 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256 aaddb20ef892dfb03d4e046cc634159bbcdfe555f7291652dde2b7d4cf491289  psplash-5b3c1cc28f5abdc2c33830150b48b278cc4f7bca.tar.gz
+sha256 0042192bf94be4f5792d9ff6b7a2ddff77c79e51274745180d14be5815b3a0f4  psplash-fd33a9b3d68c89fa22ff6873f4f9fd28bd85830c.tar.gz
 sha256 f9c375a1be4a41f7b70301dd83c91cb89e41567478859b77eef375a52d782505  COPYING
index 3dd2f4d5797fa16b4a23d77dda8a2e96e8ddde0b..39fcc2235f201c97e23c3e914a815b9b4a060fb2 100644 (file)
@@ -4,18 +4,26 @@
 #
 ################################################################################
 
-PSPLASH_VERSION = 5b3c1cc28f5abdc2c33830150b48b278cc4f7bca
+PSPLASH_VERSION = fd33a9b3d68c89fa22ff6873f4f9fd28bd85830c
 PSPLASH_SITE = git://git.yoctoproject.org/psplash
 PSPLASH_LICENSE = GPL-2.0+
 PSPLASH_LICENSE_FILES = COPYING
 PSPLASH_AUTORECONF = YES
+PSPLASH_DEPENDENCIES = host-pkgconf
+
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+PSPLASH_DEPENDENCIES += systemd
+PSPLASH_CONF_OPTS += --with-systemd
+else
+PSPLASH_CONF_OPTS += --without-systemd
+endif
 
 define PSPLASH_INSTALL_INIT_SYSTEMD
        $(INSTALL) -D -m 644 package/psplash/psplash-start.service \
                $(TARGET_DIR)/usr/lib/systemd/system/psplash-start.service
 
-       $(INSTALL) -D -m 644 package/psplash/psplash-quit.service \
-               $(TARGET_DIR)/usr/lib/systemd/system/psplash-quit.service
+       $(INSTALL) -D -m 644 package/psplash/psplash-systemd.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/psplash-systemd.service
 endef
 
 $(eval $(autotools-package))