package/python-txdbus: new package
authorMatt Weber <matthew.weber@rockwellcollins.com>
Fri, 31 May 2019 17:16:53 +0000 (12:16 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 20 Jun 2019 20:19:58 +0000 (22:19 +0200)
Implements a native Python implementation of DBus for Twisted.

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-txdbus/Config.in [new file with mode: 0644]
package/python-txdbus/python-txdbus.hash [new file with mode: 0644]
package/python-txdbus/python-txdbus.mk [new file with mode: 0644]

index 470ee31a21f2b65ce3d00814b51b88b6e42f5b41..32fa00fdd9328f171d799032ff1925a639f220f3 100644 (file)
@@ -1533,6 +1533,7 @@ F:        package/python-posix-ipc/
 F:     package/python-pypcap/
 F:     package/python-pyrex/
 F:     package/python-tinyrpc/
+F:     package/python-txdbus/
 F:     package/raptor/
 F:     package/rcw/
 F:     package/rng-tools/
index c1056e0c79eff4dea085ff3612e193b8d55e0751..96282437514776d11199c834394231a24f2d8927 100644 (file)
@@ -1083,6 +1083,7 @@ menu "External python modules"
        source "package/python-treq/Config.in"
        source "package/python-twisted/Config.in"
        source "package/python-txaio/Config.in"
+       source "package/python-txdbus/Config.in"
        source "package/python-txtorcon/Config.in"
        source "package/python-typepy/Config.in"
        source "package/python-typing/Config.in"
diff --git a/package/python-txdbus/Config.in b/package/python-txdbus/Config.in
new file mode 100644 (file)
index 0000000..f38bbf9
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_TXDBUS
+       bool "python-txdbus"
+       select BR2_PACKAGE_PYTHON_TWISTED # runtime
+       select BR2_PACKAGE_PYTHON_SIX # runtime
+       help
+         A native Python implementation of the DBus protocol for
+         Twisted applications.
+
+         https://github.com/cocagne/txdbus
diff --git a/package/python-txdbus/python-txdbus.hash b/package/python-txdbus/python-txdbus.hash
new file mode 100644 (file)
index 0000000..38760fa
--- /dev/null
@@ -0,0 +1,3 @@
+# md5, sha256 from https://pypi.org/pypi/txdbus/json
+md5    f17c9204c7f56365c297ba68e6840900  txdbus-1.1.0.tar.gz
+sha256 6ff57f42c58d935956024b3c6824c1019db7d233d0af86aa0573b73b63b0817c  txdbus-1.1.0.tar.gz
diff --git a/package/python-txdbus/python-txdbus.mk b/package/python-txdbus/python-txdbus.mk
new file mode 100644 (file)
index 0000000..08429ba
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-txdbus
+#
+################################################################################
+
+PYTHON_TXDBUS_VERSION = 1.1.0
+PYTHON_TXDBUS_SOURCE = txdbus-$(PYTHON_TXDBUS_VERSION).tar.gz
+PYTHON_TXDBUS_SITE = https://files.pythonhosted.org/packages/8e/7c/0b8726b82943ae99dc71b8fe20e2e0beb7feb4ef61105865021a64f08b16
+PYTHON_TXDBUS_SETUP_TYPE = setuptools
+PYTHON_TXDBUS_LICENSE = MIT
+
+$(eval $(python-package))