python-prompt-toolkit: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Tue, 12 Jul 2016 07:39:03 +0000 (09:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 15 Jul 2016 12:48:49 +0000 (14:48 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-prompt-toolkit/Config.in [new file with mode: 0644]
package/python-prompt-toolkit/python-prompt-toolkit.hash [new file with mode: 0644]
package/python-prompt-toolkit/python-prompt-toolkit.mk [new file with mode: 0644]

index 07e7887e6cb3f69950886c76772dac96763c3d9d..32c3e1cd0968e8f85a1054e5d8eba924e6f6e3bc 100644 (file)
@@ -702,6 +702,7 @@ menu "External python modules"
        source "package/python-pexpect/Config.in"
        source "package/python-pillow/Config.in"
        source "package/python-posix-ipc/Config.in"
+       source "package/python-prompt-toolkit/Config.in"
        source "package/python-protobuf/Config.in"
        source "package/python-psutil/Config.in"
        source "package/python-ptyprocess/Config.in"
diff --git a/package/python-prompt-toolkit/Config.in b/package/python-prompt-toolkit/Config.in
new file mode 100644 (file)
index 0000000..ccc9ebb
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_PROMPT_TOOLKIT
+       bool "python-prompt-toolkit"
+       select BR2_PACKAGE_PYTHON_SIX # runtime
+       select BR2_PACKAGE_PYTHON_WCWIDTH # runtime
+       help
+         Library for building powerful interactive command lines in
+         Python.
+
+         https://github.com/jonathanslenders/python-prompt-toolkit
diff --git a/package/python-prompt-toolkit/python-prompt-toolkit.hash b/package/python-prompt-toolkit/python-prompt-toolkit.hash
new file mode 100644 (file)
index 0000000..f33e99a
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/prompt_toolkit/json, sha256 locally computed
+md5    6c4133d099603f496c761491043bf0ef  prompt_toolkit-1.0.3.tar.gz
+sha256 805e026f0cbad27467e93f9dd3e3777718d401a62788c1e84ca038e967ad8ba2  prompt_toolkit-1.0.3.tar.gz
diff --git a/package/python-prompt-toolkit/python-prompt-toolkit.mk b/package/python-prompt-toolkit/python-prompt-toolkit.mk
new file mode 100644 (file)
index 0000000..634f20e
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-prompt-toolkit
+#
+################################################################################
+
+PYTHON_PROMPT_TOOLKIT_VERSION = 1.0.3
+PYTHON_PROMPT_TOOLKIT_SOURCE = prompt_toolkit-$(PYTHON_PROMPT_TOOLKIT_VERSION).tar.gz
+PYTHON_PROMPT_TOOLKIT_SITE = https://pypi.python.org/packages/8d/de/412f23919929c01e6b55183e124623f705e4b91796d3d2dce2cb53d595ad
+PYTHON_PROMPT_TOOLKIT_SETUP_TYPE = setuptools
+PYTHON_PROMPT_TOOLKIT_LICENSE = BSD-3c
+PYTHON_PROMPT_TOOLKIT_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))