projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3349948
)
mbedtls: fix companion programs static build
author
Baruch Siach
<baruch@tkos.co.il>
Tue, 12 Apr 2016 18:46:00 +0000
(21:46 +0300)
committer
Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>
Sat, 28 May 2016 17:22:14 +0000
(19:22 +0200)
Set LINK_WITH_PTHREAD to explicitly add pthread to the list of libraries.
Fixes:
http://autobuild.buildroot.net/results/e08/
e087dfa2a6057b18209cd6adff2760026a9ca1db
/
http://autobuild.buildroot.net/results/615/
61565f1a88b7d6eea03a355ccf8dd3fe6585c4ab
/
http://autobuild.buildroot.net/results/6b2/
6b267b9cba37655e7d8e6d78821f96d9a8dd7d2e
/
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mbedtls/mbedtls.mk
patch
|
blob
|
history
diff --git
a/package/mbedtls/mbedtls.mk
b/package/mbedtls/mbedtls.mk
index fe166e21f4dbdcceaca3d682c4489bd5d1560caf..994a3f40a8081d1e04c77589c98854ef9001e57e 100644
(file)
--- a/
package/mbedtls/mbedtls.mk
+++ b/
package/mbedtls/mbedtls.mk
@@
-23,6
+23,9
@@
define MBEDTLS_ENABLE_THREADING
$(@D)/include/mbedtls/config.h
endef
MBEDTLS_POST_PATCH_HOOKS += MBEDTLS_ENABLE_THREADING
+ifeq ($(BR2_STATIC_LIBS),y)
+MBEDTLS_CONF_OPTS += -DLINK_WITH_PTHREAD=ON
+endif
endif
ifeq ($(BR2_STATIC_LIBS),y)