pinentry: add host-pkgconf dependency
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 28 Dec 2015 11:27:57 +0000 (12:27 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 28 Dec 2015 11:27:57 +0000 (12:27 +0100)
pinentry configure.ac uses PKG_CHECK_MODULES() and also manual calls
to pkg-config, to detect the availability of some libraries, so we
need to depend on host-pkgconf.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pinentry/pinentry.mk

index d3e6b7a1bec41f80e82b9a7a73eab46ca1540ecb..ab7be54d8866ba2ee72c7bac0ab443a7a030c1d4 100644 (file)
@@ -9,7 +9,9 @@ PINENTRY_SOURCE = pinentry-$(PINENTRY_VERSION).tar.bz2
 PINENTRY_SITE = ftp://ftp.gnupg.org/gcrypt/pinentry
 PINENTRY_LICENSE = GPLv2+
 PINENTRY_LICENSE_FILES = COPYING
-PINENTRY_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+PINENTRY_DEPENDENCIES = \
+       $(if $(BR2_PACKAGE_LIBICONV),libiconv) \
+       host-pkgconf
 PINENTRY_CONF_OPTS += --without-libcap       # requires PAM
 
 # build with X if available