package/libqb: needs threads and dynamic library
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 16 Jul 2021 21:04:32 +0000 (23:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 18 Jul 2021 12:01:37 +0000 (14:01 +0200)
libqb fails to build without threads or dynamic library since the
addition of the package in commit
22864d570dd18d78a77dedab8fbcc5e0122c0acc

Also add ac_cv_prog_cc_c99=-std=gnu99 to fix build failure without wchar

Fixes:
 - http://autobuild.buildroot.org/results/21c1b5d29da4949f4582056ab4e2335ec225d8d6
 - http://autobuild.buildroot.org/results/aa4df6364cdf3c862be13b6b738595f420ec6105
 - http://autobuild.buildroot.org/results/376d316094238ba7097e8bdc51960ba38532683a

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libqb/Config.in
package/libqb/libqb.mk
package/usbguard/Config.in

index 4ab010ca50674773c18d0b8caf8332ab68b71634..e481835dfc7f9f7b9751f62364d14d09892380eb 100644 (file)
@@ -1,7 +1,12 @@
 config BR2_PACKAGE_LIBQB
        bool "libqb"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_STATIC_LIBS
        select BR2_PACKAGE_LIBXML2
        help
          Library for client-server applications
 
          https://github.com/ClusterLabs/libqb
+
+comment "libqb needs a toolchain w/ threads, dynamic library"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
index a0d97d5eb863dc5d332bfad5d3839b17d5f83a39..a9cf5e3fb978f013be10f208477997c6ed816328 100644 (file)
@@ -13,4 +13,8 @@ LIBQB_INSTALL_STAGING = YES
 LIBQB_AUTORECONF = YES
 LIBQB_DEPENDENCIES = libxml2
 
+# ac_cv_prog_cc_c99 is required for BR2_USE_WCHAR=n because the C99 test
+# provided by autoconf relies on wchar_t.
+LIBQB_CONF_ENV = ac_cv_prog_cc_c99=-std=gnu99
+
 $(eval $(autotools-package))
index 582e9b385253ad1d5196cde50f66e097ad070711..34e24a21564f4c2bb42109a36ca2fbd43317c103 100644 (file)
@@ -2,9 +2,9 @@ config BR2_PACKAGE_USBGUARD
        bool "usbguard"
        depends on BR2_PACKAGE_PROTOBUF_ARCH_SUPPORTS # protobuf
        depends on BR2_INSTALL_LIBSTDCPP # protobuf
-       depends on BR2_TOOLCHAIN_HAS_THREADS # protobuf
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libqb, protobuf
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # protobuf
-       depends on !BR2_STATIC_LIBS # protobuf
+       depends on !BR2_STATIC_LIBS # libqb, protobuf
        select BR2_PACKAGE_PROTOBUF
        select BR2_PACKAGE_LIBQB
        help