gdb: do not build documentation for bfd and gprof
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Thu, 1 Oct 2015 13:23:57 +0000 (14:23 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 3 Oct 2015 21:14:27 +0000 (23:14 +0200)
Our previous patch to disable the documentation in gdb wasn't complete.
There are cases where the documentation under bfd and gprof directories
is being built, causing the subsequent failure due to missing makeinfo.
This patch fixes that problem.

Fixes:

  http://autobuild.buildroot.org/results/244/2442e697d8a300496434fd42fcb1ee3941d13e06/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gdb/gdb.mk

index 58a12323de277668dfa946416ca844d444225f5e..15f394ce1e2bf43bbc3119b34553a9fe8654a863 100644 (file)
@@ -54,6 +54,12 @@ endif
 # Prevent gdb to build the documentation
 define GDB_DISABLE_DOC
        $(SED) '/^SUBDIRS =/ s/doc//' $(@D)/gdb/Makefile.in
+       if test -e $(@D)/bfd/doc/Makefile.in ; then \
+               $(SED) 's/^INFO_DEPS =.*$$/INFO_DEPS =/' $(@D)/bfd/doc/Makefile.in ; \
+       fi
+       if test -e $(@D)/gprof/Makefile.in ; then \
+               $(SED) 's/^INFO_DEPS =.*$$/INFO_DEPS =/' $(@D)/gprof/Makefile.in ; \
+       fi
 endef
 GDB_PRE_CONFIGURE_HOOKS += GDB_DISABLE_DOC
 HOST_GDB_PRE_CONFIGURE_HOOKS += GDB_DISABLE_DOC