package/runc: add CPE variables
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 28 Jan 2021 19:53:24 +0000 (20:53 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 29 Jan 2021 08:31:04 +0000 (09:31 +0100)
cpe:2.3:a:linuxfoundation:runc is a valid CPE identifier for this
package:

https://nvd.nist.gov/products/cpe/search/results?namingFormat=2.3&keyword=cpe%3A2.3%3Aa%3Alinuxfoundation%3Arunc

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/runc/runc.mk

index 45fe1442adcba0ec0f5d56a1972063674f34d41b..0fec360d5fbb352fa780d59704021c9780c052ee 100644 (file)
@@ -4,10 +4,13 @@
 #
 ################################################################################
 
-RUNC_VERSION = 1.0.0-rc92
+RUNC_VERSION = $(RUNC_CPE_ID_VERSION)-$(RUNC_CPE_ID_VERSION_MINOR)
 RUNC_SITE = $(call github,opencontainers,runc,v$(RUNC_VERSION))
 RUNC_LICENSE = Apache-2.0
 RUNC_LICENSE_FILES = LICENSE
+RUNC_CPE_ID_VENDOR = linuxfoundation
+RUNC_CPE_ID_VERSION = 1.0.0
+RUNC_CPE_ID_VERSION_MINOR = rc92
 
 RUNC_LDFLAGS = -X main.version=$(RUNC_VERSION)
 RUNC_TAGS = cgo static_build