ncmpc: add optional dependency to lirc-tools
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 2 Apr 2018 11:10:18 +0000 (13:10 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Apr 2018 13:11:49 +0000 (15:11 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ncmpc/ncmpc.mk

index 6bce627562bf3b698298073dfcb36df3f9b0bf06..1d464b72de34d8742d6e5fda8d6a672be665f916 100644 (file)
@@ -18,6 +18,13 @@ NCMPC_CONF_OPTS += \
        --buildtype $(if $(BR2_ENABLE_DEBUG),debug,release) \
        --cross-file $(HOST_DIR)/etc/meson/cross-compilation.conf
 
+ifeq ($(BR2_PACKAGE_LIRC_TOOLS),y)
+NCMPC_DEPENDENCIES += lirc-tools
+NCMPC_CONF_OPTS += -Dlirc=true
+else
+NCMPC_CONF_OPTS += -Dlirc=false
+endif
+
 NCMPC_NINJA_OPTS = $(if $(VERBOSE),-v)
 
 define NCMPC_CONFIGURE_CMDS