package: Add new <pkg>-show-depends to list dependencies
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 6 May 2010 08:05:43 +0000 (10:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 21 May 2010 13:07:33 +0000 (15:07 +0200)
The new <pkg>-show-depends simply outputs the list of dependencies for
the given package.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.package.in

index c2f86c7beda116c9f2110f6bd053db283ea4abf0..cdf49f8fef6493d9b7e40d120e2778bb8f1d54c0 100644 (file)
@@ -338,6 +338,9 @@ $(1)-extract:               $(1)-depends \
 
 $(1)-depends:          $(1)-source $$($(2)_DEPENDENCIES)
 
+$(1)-show-depends:
+                       @echo $$($(2)_DEPENDENCIES)
+
 $(1)-source:           $$($(2)_TARGET_SOURCE)
 
 $(1)-uninstall:                $(1)-configure $$($(2)_TARGET_UNINSTALL)