package/boost: add BR2_PACKAGE_BOOST_NOWIDE
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 28 Dec 2020 13:13:53 +0000 (14:13 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 28 Dec 2020 21:27:59 +0000 (22:27 +0100)
nowide library has been added in version 1.73.0 and is enabled by
default

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/boost/Config.in
package/boost/boost.mk

index 121650b8bc3c186726243256b01577972820e72c..ba5bffd94e94cf211153f1edd51df971a7dd7038 100644 (file)
@@ -253,6 +253,11 @@ config BR2_PACKAGE_BOOST_MPI
          Message Passing Interface library, for use in
          distributed-memory parallel application programming.
 
+config BR2_PACKAGE_BOOST_NOWIDE
+       bool "boost-nowide"
+       help
+         Library for cross-platform, unicode aware programming.
+
 config BR2_PACKAGE_BOOST_PROGRAM_OPTIONS
        bool "boost-program_options"
        help
index 82fe42d6b251dc0dca1968926917a0d1944b9ea3..365d4342b838c498b4c7d7e035678e762d65cbd2 100644 (file)
@@ -19,8 +19,8 @@ BOOST_IGNORE_CVES += CVE-2009-3654
 HOST_BOOST_FLAGS = --without-icu --with-toolset=gcc \
        --without-libraries=$(subst $(space),$(comma),atomic chrono context \
        contract coroutine date_time exception filesystem graph graph_parallel \
-       iostreams locale log math mpi program_options python random regex \
-       serialization system test thread timer type_erasure wave)
+       iostreams locale log math mpi nowide program_options python random \
+       regex serialization system test thread timer type_erasure wave)
 
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_ATOMIC),,atomic)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
@@ -39,6 +39,7 @@ BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_LOCALE),,locale)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_LOG),,log)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_MATH),,math)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_MPI),,mpi)
+BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_NOWIDE),,nowide)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_PROGRAM_OPTIONS),,program_options)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_PYTHON),,python)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_RANDOM),,random)