- add a simple cpio target, to be used with an initramfs.
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 22 Nov 2006 19:10:59 +0000 (19:10 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 22 Nov 2006 19:10:59 +0000 (19:10 -0000)
  Thanks to Goetz Bock

target/Config.in
target/cpio/Config.in [new file with mode: 0644]
target/cpio/cpioroot.mk [new file with mode: 0644]

index f59f7de5f443ef8f3262d57d54d2919d7f253eff..6bce09b4d5a09201da5bef1067110b1d36f4f7c2 100644 (file)
@@ -8,6 +8,7 @@ source "target/ext2/Config.in"
 source "target/jffs2/Config.in"
 source "target/squashfs/Config.in"
 source "target/tar/Config.in"
+source "target/cpio/Config.in"
 source "target/iso9660/Config.in"
 
 comment "bootloader for target device"
diff --git a/target/cpio/Config.in b/target/cpio/Config.in
new file mode 100644 (file)
index 0000000..0de70f9
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_TARGET_ROOTFS_CPIO
+       bool "cpio the root filesystem"
+       default n
+       help
+         Build a cpio archive of the root filesystem
+
diff --git a/target/cpio/cpioroot.mk b/target/cpio/cpioroot.mk
new file mode 100644 (file)
index 0000000..d85ee34
--- /dev/null
@@ -0,0 +1,45 @@
+#############################################################
+#
+# cpio to archive target filesystem
+#
+#############################################################
+
+CPIO_TARGET:=$(IMAGE).cpio
+
+cpioroot-init:
+       ln -s sbin/init $(TARGET_DIR)/init
+
+cpioroot: host-fakeroot makedevs cpioroot-init
+       -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
+       @rm -rf $(TARGET_DIR)/usr/man
+       @rm -rf $(TARGET_DIR)/usr/info
+       -/sbin/ldconfig -r $(TARGET_DIR) 2>/dev/null
+       # Use fakeroot to pretend all target binaries are owned by root
+       rm -f $(STAGING_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
+       touch $(STAGING_DIR)/.fakeroot.00000
+       cat $(STAGING_DIR)/.fakeroot* > $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
+       echo "chown -R root:root $(TARGET_DIR)" >> $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
+       # Use fakeroot to pretend to create all needed device nodes
+       echo "$(STAGING_DIR)/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \
+               >> $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
+       # Use fakeroot so tar believes the previous fakery
+       echo "cd $(TARGET_DIR) && find . | cpio --quiet -o -H newc > $(CPIO_TARGET)" \
+               >> $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
+       chmod a+x $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
+       $(STAGING_DIR)/usr/bin/fakeroot -- $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
+       #-@rm -f $(STAGING_DIR)/_fakeroot.$(notdir $(CPIO_TARGET))
+
+cpioroot-source:
+
+cpioroot-clean:
+
+cpioroot-dirclean:
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_TARGET_ROOTFS_CPIO)),y)
+TARGETS+=cpioroot
+endif