package/gstreamer1/gst1-plugins-bad: add wpe plugin option
authorJames Hilliard <james.hilliard1@gmail.com>
Wed, 5 Jun 2019 05:51:25 +0000 (23:51 -0600)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 8 Jun 2019 20:41:18 +0000 (22:41 +0200)
Removed gst1-plugins-bad dependency from wpewebkit gstreamer-gl option
so that there isn't a circular dependency with gst1-plugins-bad.

It appears that wpewebkit gstreamer-gl only has a runtime dependency on
gst1-plugins-bad.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Reviewed-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
package/wpewebkit/wpewebkit.mk

index fa04a23bdfdfc367ce79a6c6603ac55e6af4555f..f00f3edb7c59ed79c4cdb83218ddd1f15e612d16 100644 (file)
@@ -591,6 +591,16 @@ comment "webrtcdsp needs a toolchain w/ C++, NPTL, gcc >= 4.8"
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS_NPTL \
                || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WPE
+       bool "wpe"
+       default y
+       depends on BR2_PACKAGE_WPEWEBKIT
+       depends on BR2_PACKAGE_GST1_PLUGINS_BASE_HAS_LIB_OPENGL
+
+comment "wpe needs the gst1-plugins-base opengl library and wpewebkit"
+       depends on !BR2_PACKAGE_WPEWEBKIT \
+               || !BR2_PACKAGE_GST1_PLUGINS_BASE_HAS_LIB_OPENGL
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_X265
        bool "x265"
        depends on BR2_INSTALL_LIBSTDCPP
index e21ffae3d97b54f653cfebd46d29ce1ff04cd57f..9c238771e2e159c8cadd0d04343288f2b3ac7992 100644 (file)
@@ -698,6 +698,13 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-webrtcdsp
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WPE),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-wpe
+GST1_PLUGINS_BAD_DEPENDENCIES += wpewebkit
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-wpe
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_X265),y)
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-x265
 GST1_PLUGINS_BAD_DEPENDENCIES += x265
index b59a1f793ae5dba47d6b8c9fdb44beb2a11cb36f..4dc4a29064f984114d28a1bd9d94a47ceefa8bd5 100644 (file)
@@ -34,7 +34,6 @@ endif
 
 ifeq ($(BR2_PACKAGE_WPEWEBKIT_USE_GSTREAMER_GL),y)
 WPEWEBKIT_CONF_OPTS += -DUSE_GSTREAMER_GL=ON
-WPEWEBKIT_DEPENDENCIES += gst1-plugins-bad
 else
 WPEWEBKIT_CONF_OPTS += -DUSE_GSTREAMER_GL=OFF
 endif