- make sure that sstrip is available early enough
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 21 Aug 2007 20:14:23 +0000 (20:14 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 21 Aug 2007 20:14:23 +0000 (20:14 -0000)
toolchain/dependencies/dependencies.mk

index b18ffc050b00c0ee30ff80f2d2ad0cba3e9cc319..4af03b8f8a92f2628072aa2d67ef209f3111e32a 100644 (file)
@@ -5,7 +5,11 @@
 #
 ######################################################################
 
-dependencies: host-sed host-lzma
+ifeq ($(BR2_STRIP_sstrip),y)
+# XXX: this is a little bit ugly, yep.
+MAYBE_SSTRIP_HOST:=sstrip_host
+endif
+dependencies: host-sed host-lzma $(MAYBE_SSTRIP_HOST)
        @HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
                HOST_SED_DIR="$(HOST_SED_DIR)" \
                $(TOPDIR)/toolchain/dependencies/dependencies.sh