gtk2-themes: normalize package name and directory
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 19 Sep 2011 20:53:06 +0000 (22:53 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 20 Sep 2011 20:46:13 +0000 (22:46 +0200)
[Peter: fix directory argument of AUTOTARGETS macro]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gtk2-themes/Config.in
package/gtk2-themes/gtk2-theme-hicolor/Config.in [new file with mode: 0644]
package/gtk2-themes/gtk2-theme-hicolor/gtk2-theme-hicolor.mk [new file with mode: 0644]
package/gtk2-themes/gtk2-themes.mk [new file with mode: 0644]
package/gtk2-themes/gtk2_themes.mk [deleted file]

index 351b602c0502988061d9dac6734603c1b6c8adf0..ac212b898b3143285242c222336fbe2a89772084 100644 (file)
@@ -1,7 +1,6 @@
 menu "GTK Themes"
 depends on BR2_PACKAGE_LIBGTK2
 
-config BR2_PACKAGE_GTK2_THEME_HICOLOR
-       bool "hicolor (default theme)"
+source "package/gtk2-themes/gtk2-theme-hicolor/Config.in"
 
 endmenu
diff --git a/package/gtk2-themes/gtk2-theme-hicolor/Config.in b/package/gtk2-themes/gtk2-theme-hicolor/Config.in
new file mode 100644 (file)
index 0000000..144f1d8
--- /dev/null
@@ -0,0 +1,2 @@
+config BR2_PACKAGE_GTK2_THEME_HICOLOR
+       bool "hicolor (default theme)"
diff --git a/package/gtk2-themes/gtk2-theme-hicolor/gtk2-theme-hicolor.mk b/package/gtk2-themes/gtk2-theme-hicolor/gtk2-theme-hicolor.mk
new file mode 100644 (file)
index 0000000..ac2eaef
--- /dev/null
@@ -0,0 +1,18 @@
+#############################################################
+#
+# GTK Theme - Hicolour
+#
+#############################################################
+GTK2_THEME_HICOLOR_VERSION = 0.10
+GTK2_THEME_HICOLOR_SOURCE = hicolor-icon-theme-$(GTK2_THEME_HICOLOR_VERSION).tar.gz
+GTK2_THEME_HICOLOR_SITE = http://icon-theme.freedesktop.org/releases/
+GTK2_THEME_HICOLOR_INSTALL_STAGING = NO
+GTK2_THEME_HICOLOR_INSTALL_TARGET = YES
+
+GTK2_THEME_HICOLOR_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
+        --build=$(GNU_HOST_NAME) --prefix=/usr \
+        --includedir=/usr/include
+
+GTK2_THEME_HICOLOR_DEPENDENCIES = libgtk2
+
+$(eval $(call AUTOTARGETS,package/gtk2-themes,gtk2-theme-hicolor))
diff --git a/package/gtk2-themes/gtk2-themes.mk b/package/gtk2-themes/gtk2-themes.mk
new file mode 100644 (file)
index 0000000..6f31c6d
--- /dev/null
@@ -0,0 +1 @@
+include package/gtk2-themes/*/*.mk
diff --git a/package/gtk2-themes/gtk2_themes.mk b/package/gtk2-themes/gtk2_themes.mk
deleted file mode 100644 (file)
index 8dc8af4..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#############################################################
-#
-# GTK Theme - Hicolour
-#
-#############################################################
-GTK2_THEME_HICOLOR_VERSION = 0.10
-GTK2_THEME_HICOLOR_SOURCE = hicolor-icon-theme-$(GTK2_THEME_HICOLOR_VERSION).tar.gz
-GTK2_THEME_HICOLOR_SITE = http://icon-theme.freedesktop.org/releases/
-GTK2_THEME_HICOLOR_INSTALL_STAGING = NO
-GTK2_THEME_HICOLOR_INSTALL_TARGET = YES
-
-GTK2_THEME_HICOLOR_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
-        --build=$(GNU_HOST_NAME) --prefix=/usr \
-        --includedir=/usr/include
-
-GTK2_THEME_HICOLOR_DEPENDENCIES = libgtk2
-
-$(eval $(call AUTOTARGETS,package,gtk2_theme_hicolor))