icu: remove dev files
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 9 Mar 2016 16:25:22 +0000 (13:25 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Mar 2016 21:16:13 +0000 (22:16 +0100)
Remove files that aren't used for runtime purposes.

Size savings delta +450 KB.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/icu/icu.mk

index b4574e5be5dde4411b642c55dd90d86713b5709a..68ea1ff7c4e3fb48160d3e7db40c42dc3aace149 100644 (file)
@@ -44,5 +44,12 @@ endef
 ICU_POST_PATCH_HOOKS += ICU_COPY_CUSTOM_DATA
 endif
 
+define ICU_REMOVE_DEV_FILES
+       rm -f $(addprefix $(TARGET_DIR)/usr/bin/,derb genbrk gencfu gencnval gendict genrb icuinfo makeconv uconv)
+       rm -f $(addprefix $(TARGET_DIR)/usr/sbin/,genccode gencmn gennorm2 gensprep icupkg)
+       rm -rf $(TARGET_DIR)/usr/share/icu
+endef
+ICU_POST_INSTALL_TARGET_HOOKS += ICU_REMOVE_DEV_FILES
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))