qwt: fix build when BR2_STATIC_LIBS=y
authorGwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Thu, 11 May 2017 13:46:57 +0000 (15:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 11 May 2017 15:52:54 +0000 (17:52 +0200)
By default, qwt build a shared library, but when BR2_STATIC_LIBS is set
compilation failed with errors like :
__uClibc_main.c:(.text+0x164): undefined reference to `__fini_array_end'
__uClibc_main.c:(.text+0x168): undefined reference to `__fini_array_start'
__uClibc_main.c:(.text+0x16c): undefined reference to `__fini_array_start'

This patch disable QwtDll to build a static library when BR2_STATIC_LIBS=y.

fix:
http://autobuild.buildroot.net/results/739/739406bb8073d1861933872a47802954d9767634/

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qwt/qwt.mk

index d4e6d52c13cb62c2fd0c7b04f8d88edca0d79985..619453bfc9d82c050aa2e284aa46bdf4dc663c4e 100644 (file)
@@ -41,6 +41,12 @@ else
 QWT_CONFIG += -e 's/^.*QWT_CONFIG.*QwtOpenGL.*$$/\# QWT_CONFIG += QwtOpenGL/'
 endif
 
+ifeq ($(BR2_STATIC_LIBS),y)
+QWT_CONFIG += -e 's/^.*QWT_CONFIG.*QwtDll.*$$/\# QWT_CONFIG += QwtDll/'
+else
+QWT_CONFIG += -e 's/^.*QWT_CONFIG.*QwtDll.*$$/QWT_CONFIG += QwtDll/'
+endif
+
 define QWT_CONFIGURE_CMDS
        $(SED) $(QWT_CONFIG) $(@D)/qwtconfig.pri
        (cd $(@D); $(TARGET_MAKE_ENV) $(QWT_QMAKE))