package/mplayer: add optional fontconfig support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 Mar 2015 17:11:22 +0000 (19:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 7 Apr 2015 21:12:15 +0000 (23:12 +0200)
[Thomas: rely on autodetection.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mplayer/mplayer.mk

index b685a3862ac2a9871d475bfea1ba51787648136d..7a88b7418cf3a25031a760a83c213003fd3f9139 100644 (file)
@@ -45,6 +45,14 @@ else
 MPLAYER_CONF_OPTS += --disable-freetype
 endif
 
+# We intentionally don't pass --enable-fontconfig, to let the
+# autodetection find which library to link with.
+ifeq ($(BR2_PACKAGE_FONTCONFIG),y)
+MPLAYER_DEPENDENCIES += fontconfig
+else
+MPLAYER_CONF_OPTS += --disable-fontconfig
+endif
+
 # We intentionally don't pass --enable-termcap, in order to let the
 # autodetection find with which library to link with. Otherwise, we
 # would have to pass it manually.