hdparm: prevent package makefile from stripping the hdparm binary
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 11 Jun 2014 20:46:29 +0000 (22:46 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 11 Jun 2014 21:03:48 +0000 (23:03 +0200)
Packages shouldn't strip executables by themselves, so that Buildroot
controls whether stripping should occur or not. This also fixes the
build on Blackfin FLAT where stripping actually doesn't work because
stripping FLAT binaries is not supported.

Fixes:

  http://autobuild.buildroot.org/results/7d4/7d4e59c96928a06db5091235bf2eacf462ba8a21/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/hdparm/hdparm.mk

index 1a200fb6b40b2d91daabe8ea9034559c5a347421..0ca3c39b05e43f6f06bb5023f8767e10ac781587 100644 (file)
@@ -12,7 +12,8 @@ HDPARM_LICENSE_FILES = LICENSE.TXT
 define HDPARM_BUILD_CMDS
        $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
                CFLAGS="$(TARGET_CFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS)"
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               STRIP=/bin/true
 endef
 
 define HDPARM_INSTALL_TARGET_CMDS