hostapd: fix build with new libnl-3
authorDaniel Mack <zonque@gmail.com>
Sat, 3 Dec 2011 17:03:29 +0000 (18:03 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Dec 2011 07:41:36 +0000 (08:41 +0100)
The CFLAGS have to be augmented for the include dir and a small patch
will make the binary link to libnl-3 and libnl-genl-3 instead of libnl
and libnl-gen.

Signed-off-by: Daniel Mack <zonque@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/hostapd/hostapd-0.7.3-libnl3.patch [new file with mode: 0644]
package/hostapd/hostapd.mk

diff --git a/package/hostapd/hostapd-0.7.3-libnl3.patch b/package/hostapd/hostapd-0.7.3-libnl3.patch
new file mode 100644 (file)
index 0000000..e47da73
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/src/drivers/drivers.mak  2011-11-29 19:09:23.889942913 +0100
++++ b/src/drivers/drivers.mak  2011-11-29 19:09:40.637381428 +0100
+@@ -31,10 +31,10 @@
+ NEED_AP_MLME=y
+ NEED_NETLINK=y
+ NEED_LINUX_IOCTL=y
+-DRV_LIBS += -lnl
++DRV_LIBS += -lnl-3
+ ifdef CONFIG_LIBNL20
+-DRV_LIBS += -lnl-genl
++DRV_LIBS += -lnl-genl-3
+ DRV_CFLAGS += -DCONFIG_LIBNL20
+ endif
+ endif
index 0d6c2c53a54f00c00f7b80b227e5b7a243675b69..26ebf1de0b2a11a4bf7333a685c47b3c4dae67da 100644 (file)
@@ -18,6 +18,7 @@ endif
 
 define HOSTAPD_LIBNL_CONFIG
        echo "CONFIG_LIBNL20=y" >>$(HOSTAPD_CONFIG)
+       echo "CFLAGS += -I$(STAGING_DIR)/usr/include/libnl3/" >>$(HOSTAPD_CONFIG)
 endef
 
 define HOSTAPD_CRYPTO_CONFIG