geoip: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 17 Jun 2014 14:39:22 +0000 (11:39 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Jun 2014 18:35:49 +0000 (20:35 +0200)
[Thomas: slightly reformat the Config.in help text. Add the 'LICENSE'
file to GEOIP_LICENSE_FILES.]

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/geoip/Config.in [new file with mode: 0644]
package/geoip/geoip.mk [new file with mode: 0644]

index 12640537a56dd818e5a5927a82d214971a284b91..4718719451a01f76993bd138ad02d042d44eae38 100644 (file)
@@ -720,6 +720,7 @@ menu "Networking"
        source "package/czmq/Config.in"
        source "package/filemq/Config.in"
        source "package/fmlib/Config.in"
+       source "package/geoip/Config.in"
        source "package/glib-networking/Config.in"
        source "package/libcgi/Config.in"
        source "package/libcgicc/Config.in"
diff --git a/package/geoip/Config.in b/package/geoip/Config.in
new file mode 100644 (file)
index 0000000..739a8da
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_GEOIP
+       bool "geoip"
+       help
+         GeoIP is a C library that enables the user to find
+         geographical and network information of an IP address.
+
+         To use this library, you need to download MaxMind's free
+         GeoLite or commercial GeoIP binary databases into the
+         target's /usr/share/GeoIP directory in uncompressed form.
+
+         Note that GeoIP2 / GeoLite2 are not supported by this
+         library.
+
+         https://github.com/maxmind/geoip-api-c
diff --git a/package/geoip/geoip.mk b/package/geoip/geoip.mk
new file mode 100644 (file)
index 0000000..bbfa014
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# geoip
+#
+################################################################################
+
+GEOIP_VERSION = 1.6.0
+GEOIP_SOURCE = GeoIP-$(GEOIP_VERSION).tar.gz
+GEOIP_SITE = $(call github,maxmind,geoip-api-c,v$(GEOIP_VERSION))
+GEOIP_AUTORECONF = YES
+GEOIP_INSTALL_STAGING = YES
+GEOIP_LICENSE = LGPLv2.1+
+GEOIP_LICENSE_FILES = LICENSE COPYING
+
+$(eval $(autotools-package))